aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2020-10-30 15:49:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-12-09 12:12:24 +0100
commit38bc0bf808c26f1c6c26234eed6e9ce472de1b24 (patch)
tree801a641f710d735a02dd4659273267176def7920 /gnu/packages
parent532b1068563326c5a2279346bd80412e80e39d23 (diff)
downloadguix-38bc0bf808c26f1c6c26234eed6e9ce472de1b24.tar.gz
guix-38bc0bf808c26f1c6c26234eed6e9ce472de1b24.zip
gnu: r-monocle: Update to 2.18.0.
* gnu/packages/bioconductor.scm (r-monocle): Update to 2.18.0.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/bioconductor.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 091ba62ed4..c03f83f630 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2981,14 +2981,14 @@ single cell assay data.")
(define-public r-monocle
(package
(name "r-monocle")
- (version "2.16.0")
+ (version "2.18.0")
(source
(origin
(method url-fetch)
(uri (bioconductor-uri "monocle" version))
(sha256
(base32
- "1vziidavlyhixmx6j7lf29qx8xcjwrc9q3x2f63gcff41q3jf9xd"))))
+ "1k3hwi9aspjy75arigg7i1w7ygf112y12cndibf2bhpz2phzwslx"))))
(build-system r-build-system)
(propagated-inputs
`(("r-biobase" ,r-biobase)
keyword-arguments" '((#:foo 2) (#:foo 2) (#:foo 2 #:bar 3) (#:foo 2 #:bar 3) (#:foo 2 #:bar 3)) (list (default-keyword-arguments '() '(#:foo 2)) (default-keyword-arguments '(#:foo 2) '(#:foo 4)) (default-keyword-arguments '() '(#:bar 3 #:foo 2)) (default-keyword-arguments '(#:bar 3) '(#:foo 2)) (default-keyword-arguments '(#:foo 2 #:bar 3) '(#:bar 6)))) (test-equal "substitute-keyword-arguments" '((#:foo 3) (#:foo 3) (#:foo 3 #:bar (1 2)) (#:bar (1 2) #:foo 3) (#:foo 3)) (list (substitute-keyword-arguments '(#:foo 2) ((#:foo f) (1+ f))) (substitute-keyword-arguments '() ((#:foo f 2) (1+ f))) (substitute-keyword-arguments '(#:foo 2 #:bar (2)) ((#:foo f) (1+ f)) ((#:bar b) (cons 1 b))) (substitute-keyword-arguments '(#:foo 2) ((#:foo _) 3) ((#:bar b '(2)) (cons 1 b))) (substitute-keyword-arguments '(#:foo 2) ((#:foo f 1) (1+ f)) ((#:bar b) (cons 42 b))))) (test-assert "filtered-port, file" (let* ((file (search-path %load-path "guix.scm")) (input (open-file file "r0b"))) (let*-values (((compressed pids1) (filtered-port `(,%gzip "-c" "--fast") input)) ((decompressed pids2) (filtered-port `(,%gzip "-d") compressed))) (and (every (compose zero? cdr waitpid) (append pids1 pids2)) (equal? (get-bytevector-all decompressed) (call-with-input-file file get-bytevector-all)))))) (test-assert "filtered-port, non-file" (let ((data (call-with-input-file (search-path %load-path "guix.scm") get-bytevector-all))) (let*-values (((compressed pids1) (filtered-port `(,%gzip "-c" "--fast") (open-bytevector-input-port data))) ((decompressed pids2) (filtered-port `(,%gzip "-d") compressed))) (and (pk (every (compose zero? cdr waitpid) (append pids1 pids2))) (equal? (get-bytevector-all decompressed) data))))) (test-assert "filtered-port, does not exist" (let* ((file (search-path %load-path "guix.scm")) (input (open-file file "r0b"))) (let-values (((port pids) (filtered-port '("/does/not/exist") input))) (any (compose (negate zero?) cdr waitpid) pids)))) (define (test-compression/decompression method run?) "Test METHOD, a symbol such as 'gzip. Call RUN? to determine whether to skip these tests." (unless (run?) (test-skip 1)) (test-assert (format #f "compressed-port, decompressed-port, non-file [~a]" method) (let ((data (call-with-input-file (search-path %load-path "guix.scm") get-bytevector-all))) (call-with-temporary-output-file (lambda (output port) (close-port port) (let*-values (((compressed pids) ;; Note: 'compressed-output-port' only supports file ;; ports. (compressed-output-port method (open-file output "w0")))) (put-bytevector compressed data) (close-port compressed) (and (every (compose zero? cdr waitpid) (pk 'pids method pids)) (let*-values (((decompressed pids) (decompressed-port method (open-bytevector-input-port (call-with-input-file output get-bytevector-all)))) ((result) (get-bytevector-all decompressed))) (close-port decompressed) (pk 'len method (if (bytevector? result) (bytevector-length result) result) (bytevector-length data)) (and (every (compose zero? cdr waitpid) (pk 'pids method pids)) (equal? result data))))))))) (false-if-exception (delete-file temp-file)) (unless (run?) (test-skip 1)) (test-assert (format #f "compressed-output-port + decompressed-port [~a]" method) (let* ((file (search-path %load-path "guix/derivations.scm")) (data (call-with-input-file file get-bytevector-all)) (port (open-file temp-file "w0b"))) (call-with-compressed-output-port method port (lambda (compressed) (put-bytevector compressed data))) (close-port port) (bytevector=? data (call-with-decompressed-port method (open-file temp-file "r0b") get-bytevector-all))))) (for-each test-compression/decompression `(gzip xz lzip zstd) (list (const #t) (const #t) (const #t) (lambda () (resolve-module '(zstd) #t #f #:ensure #f)))) ;; This is actually in (guix store). (test-equal "store-path-package-name" "bash-4.2-p24" (store-path-package-name (string-append (%store-prefix) "/qvs2rj2ia5vci3wsdb7qvydrmacig4pg-bash-4.2-p24"))) (test-equal "canonical-newline-port" "This is a journey\nInto the sound\nA journey ...\n" (let ((port (open-string-input-port "This is a journey\r\nInto the sound\r\nA journey ...\n"))) (get-string-all (canonical-newline-port port)))) (test-equal "canonical-newline-port-1024" (string-concatenate (make-list 100 "0123456789abcde\n")) (let ((port (open-string-input-port (string-concatenate (make-list 100 "0123456789abcde\r\n"))))) (get-string-all (canonical-newline-port port)))) (test-equal "edit-expression" "(display \"GNU Guix\")\n(newline)\n" (begin (call-with-output-file temp-file (lambda (port) (display "(display \"xiuG UNG\")\n(newline)\n" port))) (edit-expression `((filename . ,temp-file) (line . 0) (column . 9)) string-reverse) (call-with-input-file temp-file get-string-all))) (test-equal "insert-expression" "(define-public package-1\n 'package)\n (define-public package-2\n 'package)\n" (begin (call-with-output-file temp-file (lambda (port) (display "(define-public package-2\n 'package)\n" port))) (insert-expression `((filename . ,temp-file) (line . 0) (column . 0)) `(define-public package-1 'package)) (call-with-input-file temp-file get-string-all))) (test-equal "find-definition-insertion-location" (list `((filename . ,temp-file) (line . 0) (column . 0)) `((filename . ,temp-file) (line . 5) (column . 0)) #f) (begin (call-with-output-file temp-file (lambda (port) (display "(define-public package-1\n 'foo)\n\n" port) (display "(define foo 'bar)\n\n" port) (display "(define-public package-2\n 'baz)\n" port))) (map (lambda (term) (find-definition-insertion-location temp-file term)) (list 'package 'package-1 'package-2)))) (test-equal "string-distance" '(0 1 1 5 5) (list (string-distance "hello" "hello") (string-distance "hello" "helo") (string-distance "helo" "hello") (string-distance "" "hello") (string-distance "hello" ""))) (test-equal "string-closest" '("hello" "hello" "helo" #f) (list (string-closest "hello" '("hello")) (string-closest "hello" '("helo" "hello" "halo")) (string-closest "hello" '("kikoo" "helo" "hihihi" "halo")) (string-closest "hello" '("aaaaa" "12345" "hellohello" "h")))) (test-equal "target-linux?" '(#t #f #f #t) (map target-linux? '("i686-linux-gnu" "i686-w64-mingw32" ;; Checking that "gnu" is present is not sufficient, ;; as GNU/Hurd exists. "i686-pc-gnu" ;; Some targets have a suffix. "arm-linux-gnueabihf"))) (test-equal "target-mingw?" '(#f #f #t) (map target-mingw? '("i686-linux-gnu" "i686-pc-gnu" "i686-w64-mingw32"))) (test-equal "target-x86-32?" '(#f #f #f #t #t #t #t #f) ;; These are (according to Wikipedia) two RISC architectures ;; by Intel and presumably not compatible with the x86-32 series. (map target-x86-32? '("i860-gnu" "i960-gnu" ;; This is a 16-bit architecture "i286-gnu" ;; These are part of the x86-32 series. "i386-gnu" "i486-gnu" "i586-gnu" "i686-gnu" ;; Maybe this one will exist some day, but not yet. "i786-gnu"))) (test-equal "target-x86-64?" '(#t #f #f #f) (map target-x86-64? `("x86_64-linux-gnu" "i386-linux-gnu" ;; Just because it includes "64" doesn't make it 64-bit. "aarch64-linux-gnu" ;; Note that (expt 2 109) in decimal notation starts with 64. ;; However, it isn't 32-bit. ,(format #f "x86_~a-linux-gnu" (expt 2 109))))) (test-equal "target-avr?" '(#t #t #t #f #f) (map target-avr? '("avr" "avr-unknown-none" ;; In addition LLVM also uses this form. "avr-unknown-unknown" ;; The AVR32 architecture also was made by Atmel/Microchip but it ;; does not resemble the AVR family, they aren't compatible in any ;; way. "avr32" "avr32-unknown-none"))) (test-end) (false-if-exception (delete-file temp-file))