aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2024-11-03 13:03:52 +0100
committerJelle Licht <jlicht@fsfe.org>2024-12-18 22:02:19 +0100
commit37ec990182034274b5614e48e24a9fa76f82ee13 (patch)
treee4babbcabbc59449c31cf76f73f6df7d2ad1aa15 /gnu/packages
parent954385d48fdcb1d439cd1e2293671559aaa08532 (diff)
downloadguix-37ec990182034274b5614e48e24a9fa76f82ee13.tar.gz
guix-37ec990182034274b5614e48e24a9fa76f82ee13.zip
gnu: Add libuv-for-node-lts.
Specific versions of Node depend on specific versions of libuv. * gnu/packages/libevent.scm (libuv-for-node-lts): New package. Change-Id: I97f6b96002dde37a0cec56dbfd7ff8722982ff89
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/libevent.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 20f967757d..202deaea47 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -158,6 +158,30 @@ resolution, asynchronous file system operations, and threading primitives.")
"0wpb9pz3r8nksnrf4zbixj2kk9whr7abi45ydrwyv2js2ljrc4j3"))))
(properties '((hidden? . #t)))))
+(define-public libuv-for-node-lts
+ ;; When upgrading Node, also upgrade this. Get the version from
+ ;; https://github.com/nodejs/node/blob/main/deps/uv/include/uv/version.h
+ (package
+ (inherit libuv)
+ (name "libuv")
+ (version "1.46.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dist.libuv.org/dist/v" version
+ "/libuv-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1knxvp6bl3y0c87cch1id0z7m7rb6igx55ci93qnbp4zifaq67qi"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Disable io_uring by default due to CVE-2024-22017. Can be removed once
+ ;; https://github.com/libuv/libuv/issues/4468 is released and compatible
+ ;; with Node.js
+ (substitute* "src/unix/linux.c"
+ (("val == NULL \\|\\|") "val != NULL &&"))))))
+ (properties '((hidden? . #t)))))
+
(define-public libuv-for-r-httpuv
;; When upgrading r-httpuv, also upgrade this.
(package