aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 19:43:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:34 +0200
commit34e2e55a1a19252d9b1e872d49e2f34a8c371631 (patch)
tree6cb233645cc5485ac1ef76c851b66b5086d13f55 /gnu/packages
parentfe3f7a1b92e842dfbf712e06c20129ecb985f523 (diff)
downloadguix-34e2e55a1a19252d9b1e872d49e2f34a8c371631.tar.gz
guix-34e2e55a1a19252d9b1e872d49e2f34a8c371631.zip
gnu: texlive-todonotes: Refresh package definition.
* gnu/packages/tex.scm (texlive-todonotes): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: TEXLIVE-TOOLS, TEXLIVE-XCOLOR.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 24 insertions, 18 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 723f10373e..d89a396c60 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10860,24 +10860,30 @@ citations and references.")
(license license:lppl1.3c)))
(define-public texlive-todonotes
- (let ((template (simple-texlive-package
- "texlive-todonotes"
- (list "/doc/latex/todonotes/"
- "/tex/latex/todonotes/")
- (base32
- "1jqw8jy73488bdr971w0dnlggsvicagpnpx8ddqkma920ba8rabp")
- #:trivial? #t)))
- (package
- (inherit template)
- (propagated-inputs
- (list texlive-pgf texlive-xkeyval))
- (home-page "http://www.ctan.org/pkg/todonotes")
- (synopsis "Marking things to do in a LaTeX document")
- (description "The @code{todonotes} package lets the user mark
-things to do later, in a simple and visually appealing way. The
-package takes several options to enable customization and finetuning
-of the visual appearance.")
- (license license:lppl1.3+))))
+ (package
+ (name "texlive-todonotes")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/todonotes/"
+ "source/latex/todonotes/"
+ "tex/latex/todonotes/")
+ (base32
+ "0lhqzrvf216j3rzg7lmc1mvnr2mzr0a6c2kqrfwzw6qbpm9v29nk")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-pgf
+ texlive-tools
+ texlive-xcolor
+ texlive-xkeyval))
+ (home-page "https://ctan.org/pkg/todonotes")
+ (synopsis "Marking things to do in a LaTeX document")
+ (description
+ "The @code{todonotes} package lets the user mark things to do later, in
+a simple and visually appealing way. The package takes several options to
+enable customization and finetuning of the visual appearance.")
+ (license license:lppl1.3+)))
(define-public texlive-units
(package