aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 16:30:19 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:15 +0200
commit347a6932b099069ebe44a7e52a692ae8f8641af5 (patch)
tree067324d0e912a7bb61e493a78a6bec93275abb0c /gnu/packages
parentce749beb17e58481b24853030043b44c6c6d3e8f (diff)
downloadguix-347a6932b099069ebe44a7e52a692ae8f8641af5.tar.gz
guix-347a6932b099069ebe44a7e52a692ae8f8641af5.zip
gnu: Add texlive-afm2pl.
* gnu/packages/tex.scm (texlive-afm2pl): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 54aa4ce60d..a2837ce4ed 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1012,6 +1012,29 @@ works on TeX virtual fonts and @command{vpl2ovp} transforms a TeX font to an
Omega one.")
(license license:gpl3+)))
+(define-public texlive-afm2pl
+ (package
+ (name "texlive-afm2pl")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/afm2pl.1"
+ "doc/man/man1/afm2pl.man1.pdf"
+ "fonts/enc/dvips/afm2pl/"
+ "fonts/lig/afm2pl/" "tex/fontinst/afm2pl/")
+ (base32
+ "19llzzr4kmmyf7l18ngx1rhaqaqvgm3md924m4dxcv7nmrvga2b2")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/afm2pl")
+ (synopsis "Convert AFM to TeX property list (@file{.pl}) metrics")
+ (description
+ "@command{afm2pl} converts a @file{.afm} (Adobe Font Metric) file into
+a @file{.pl} (Property List) file, which in its turn can be converted to
+a @file{.tfm} (TeX Font Metric) file. It normally preserves kerns and
+ligatures, but also offers additional control over them.")
+ (license license:gpl2)))
+
(define-public texlive-tex
(package
(name "texlive-tex")