aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 00:33:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:17 +0200
commit3384b68dcf235829294d9e599ba5733b503feab3 (patch)
treeea6eda1a64b702020f5bf250e7506e7f2166de60 /gnu/packages
parent1dbdd0feea0d074ad60676a4d047db1fee505167 (diff)
downloadguix-3384b68dcf235829294d9e599ba5733b503feab3.tar.gz
guix-3384b68dcf235829294d9e599ba5733b503feab3.zip
gnu: Add texlive-graphviz.
* gnu/packages/tex.scm (texlive-graphviz): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bec01bb17f..88e11d63cd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -17435,6 +17435,25 @@ it.")
@code{graphicx} package with the @command{convert} command from ImageMagick.")
(license license:expat)))
+(define-public texlive-graphviz
+ (package
+ (name "texlive-graphviz")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/graphviz/"
+ "source/latex/graphviz/"
+ "tex/latex/graphviz/")
+ (base32
+ "0abg1cmzr449gd5pbg3ppgf35xixjyszy3jxnrg37kqly7c26l6s")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/graphviz")
+ (synopsis "Write Graphviz inline in LaTeX documents")
+ (description
+ "The package allows inline use of Graphviz code, in a LaTeX document.")
+ (license license:lppl1.3+)))
+
(define-public texlive-inlinedef
(package
(name "texlive-inlinedef")