aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:10:33 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-15 13:37:01 +0200
commit2f6bfb9f885adb545ac0311487d5a0bedd409fb2 (patch)
tree2274c34c20dd7521d007231761cd2ae36333c149 /gnu/packages
parent5a8b23185d3ad4ae4f4a07807447cc5b598a0322 (diff)
downloadguix-2f6bfb9f885adb545ac0311487d5a0bedd409fb2.tar.gz
guix-2f6bfb9f885adb545ac0311487d5a0bedd409fb2.zip
gnu: Add texlive-xpinyin.
* gnu/packages/tex.scm (texlive-xpinyin): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2999084f02..da0ef4426e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -23111,6 +23111,25 @@ names, as well as character data, may use any characters allowed in XML, using
UTF-8 or a suitable 8-bit encoding.")
(license license:lppl1.0+))) ;per xmltex/base/readme.txt
+(define-public texlive-xpinyin
+ (package
+ (name "texlive-xpinyin")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/xpinyin/" "source/latex/xpinyin/"
+ "tex/latex/xpinyin/")
+ (base32
+ "1fxsnvmkm66rfq08j03sch24maw0wgb8dhl73r2rf6gwxzf4imc5")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/xpinyin")
+ (synopsis "Automatically add pinyin to Chinese characters")
+ (description
+ "The package is written to simplify the input of Hanyu Pinyin. Macros are
+provided that automatically add pinyin to Chinese characters.")
+ (license license:lppl1.3c)))
+
(define-public texlive-hyperref
(package
(name "texlive-hyperref")