aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-01-12 13:17:53 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:50 +0200
commit2f59483df20582377e90b231af33f2f1e165fed7 (patch)
tree2b16d3905553b41fe2f0fd50ff5cfc28e59d245c /gnu/packages
parent4eea9f5bafcb89ee58754e16a4bf6249885203b2 (diff)
downloadguix-2f59483df20582377e90b231af33f2f1e165fed7.tar.gz
guix-2f59483df20582377e90b231af33f2f1e165fed7.zip
gnu: cryptsetup: Update to 2.6.1.
* gnu/packages/cryptsetup.scm (cryptsetup): Update to 2.6.1. Disable external tokens for now. Change-Id: I5610cabfbd46d010a8241430d8d90f5920847c04
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/cryptsetup.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/cryptsetup.scm b/gnu/packages/cryptsetup.scm
index 3bdc68ae5a..3cb669206a 100644
--- a/gnu/packages/cryptsetup.scm
+++ b/gnu/packages/cryptsetup.scm
@@ -30,12 +30,13 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages ruby)
#:use-module (gnu packages web))
(define-public cryptsetup
(package
(name "cryptsetup")
- (version "2.3.7")
+ (version "2.6.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/linux/utils/cryptsetup/v"
@@ -43,7 +44,7 @@
"/cryptsetup-" version ".tar.xz"))
(sha256
(base32
- "1a97rvi6arsj8dikh1qsvixx9rizm89k155q2ypifqlqllr530v1"))))
+ "14s6vbb9llpgnhmv0badxxzhi73jp4vyvp8swk4bjah7l5jys3a1"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -54,12 +55,16 @@
"--with-crypto_backend=gcrypt"
;; GRUB 2.06 supports LUKS2, but does it reliably support all set-ups…?
"--with-default-luks-format=LUKS1"
+ ;; External tokens would need an env variable to work on Guix, and we
+ ;; don't have users for it yet.
+ "--disable-external-tokens"
+ "--disable-ssh-token"
;; libgcrypt is not found otherwise when cross-compiling.
;; <https://issues.guix.gnu.org/63864>
(string-append "--with-libgcrypt-prefix="
(assoc-ref %build-inputs "libgcrypt")))))
(native-inputs
- (list pkg-config))
+ (list pkg-config ruby-asciidoctor))
(inputs
(list argon2
json-c