aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-08-19 10:53:20 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-19 11:05:05 +0300
commit2f3d23e12aa14b297ac0dc4c520da8a19eac3e53 (patch)
treebec52445b38b927a23f3c2847f146658ece6dd6b /gnu/packages
parentd2ec1f8ed6576b5d0df1544b2e0e6603b1adfb5d (diff)
downloadguix-2f3d23e12aa14b297ac0dc4c520da8a19eac3e53.tar.gz
guix-2f3d23e12aa14b297ac0dc4c520da8a19eac3e53.zip
gnu: waybar: Remove unrecognized configure flag.
* gnu/packages/wm.scm (waybar)[arguments]: Remove field.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/wm.scm3
1 files changed, 0 insertions, 3 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 53930d4580..bb5a91a230 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1524,9 +1524,6 @@ modules for building a Wayland compositor.")
(sha256
(base32 "0ks719khhg2zwpyiwa2079i6962qcxpapm28hmr4ckpsp2n659ck"))))
(build-system meson-build-system)
- (arguments
- `(#:configure-flags
- (list (string-append "-Dout=" (assoc-ref %outputs "out")))))
(inputs `(("date" ,date)
("fmt" ,fmt)
("gtk-layer-shell" ,gtk-layer-shell)
span class='msg-tooltip'>* gnu/system/images/pine64.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/system/image.scm (arm64-disk-image, arm64-image-type): New variables. Mathieu Othacehe 2020-09-30system: image: Add image-type support....* gnu/system/image.scm (image-with-os): New macro. Rename the old "image-with-os" procedure to ... (image-with-os*): ... this new procedure, (system-image): adapt according, (raw-image-type, iso-image-type, uncompressed-iso-image-type %image-types): new variables, (lookup-image-type-by-name): new procedure. (find-image): remove it. * gnu/system/images/hurd.scm (hurd-image-type): New variable, use it to define ... (hurd-disk-image): ... this variable, using "os->image" procedure. * gnu/tests/install.scm (run-install): Rename installation-disk-image-file-system-type parameter to installation-image-type, use os->config instead of find-image to compute the image passed to system-image, (%test-iso-image-installer) adapt accordingly, (guided-installation-test): ditto. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Mathieu Othacehe 2020-09-29images: hurd: Add hurd-barebones-qcow2-image....* gnu/system/images/hurd.scm (hurd-barebones-qcow2-image): New variable. Mathieu Othacehe 2020-07-11image: Do not set journal_model=WAL for the Hurd....This fixes <https://bugs.gnu.org/42151>. * gnu/system/images/hurd.scm (hurd-initialize-root-partition): Use #:wal-mode #f in call to ... * gnu/build/image.scm (initialize-root-partition): ... this, add #:wal-mode? parameter, pass it to ... (register-closure): ... this, add #:wal-mode? parameter, pass it to ... * guix/store/database.scm (with-database): ... this, add #:wal-mode? parameter, pass it to ... (call-with-database): ... this, add #:wal-mode? parameter; when set to #f, do not set journal_model=WAL. Jan (janneke) Nieuwenhuizen 2020-06-25image: hurd: Initialize root partition for the Hurd....This is a follow-up to commit b904b59ce592c89dfb4675a8c06757afed6738a0. * gnu/system/image.scm (hurd-initialize-root-partition): Move to ... * gnu/system/images/hurd.scm (hurd-initialize-root-partition): ... here. (hurd-disk-image): Use it. Jan (janneke) Nieuwenhuizen 2020-06-25image: hurd: Create hurd-compatible ext2 file-system....This is a follow-up to commit b904b59ce592c89dfb4675a8c06757afed6738a0. * gnu/system/images/hurd.scm (hurd-disk-image): Add file-system-options to create an ext2 file-system that is compatible with the Hurd. Jan (janneke) Nieuwenhuizen 2020-06-24image: Move hurd image definition to a dedicated file....This moves hurd-disk-image to a dedicated file. It also defines a default operating-system so that the image can be built standalone. * gnu/system/images/hurd.scm: New file, * gnu/local.mk (GNU_SYSTEM_MODULES): add it, * gnu/system/image.scm (root-offset, root-label): Export it, (hurd-disk-image): remove it as this is now defined in the new, Hurd dedicated file above, (find-image): adapt to avoid loop dependency. Mathieu Othacehe