aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorAntero Mejr <antero@mailbox.org>2023-06-04 17:41:57 +0000
committerDanny Milosavljevic <dannym@friendly-machines.com>2024-12-22 13:12:25 +0100
commit2e91e486d52990620111222d494b73096d838821 (patch)
tree443b20ec6c5963c08b36dc2da0d47cd756cd4ca9 /gnu/packages
parentefe027b1e02cfa03fa65743e42393898230194be (diff)
downloadguix-2e91e486d52990620111222d494b73096d838821.tar.gz
guix-2e91e486d52990620111222d494b73096d838821.zip
gnu: Add perl-dbix-simple.
* gnu/packages/databases.scm (perl-dbix-simple): New variable. Signed-off-by: Danny Milosavljevic <dannym@friendly-machines.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/databases.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index fd657137f2..9c72943cdd 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2324,6 +2324,32 @@ flexible than @code{DBIx::Class::Schema::Versioned}, hence the use of Moose
and lots of roles.")
(license license:perl-license)))
+(define-public perl-dbix-simple
+ (package
+ (name "perl-dbix-simple")
+ (version "1.37")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JU/JUERD/DBIx-Simple-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1qyaj01zb6xplzcp7pj0b9609fvd89c9c4an3i00g2g05jm13ls6"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-dbi))
+ (home-page "https://metacpan.org/release/DBIx-Simple")
+ (synopsis "Object-oriented interface to DBI")
+ (description
+ "DBIx::Simple provides a simplified interface to DBI, Perl's powerful
+database module. This module is aimed at rapid development and easy
+maintenance. Query preparation and execution are combined in a single method,
+the result object (which is a wrapper around the statement handle) provides
+easy row-by-row and slurping methods.")
+ ;; The POD info says: "Pick your favorite OSI-approved license"
+ ;; Use unlicense because it has the least restrictions.
+ (license license:unlicense)))
+
(define-public perl-dbd-pg
(package
(name "perl-dbd-pg")