aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-09-17 11:15:23 +0200
committerLudovic Courtès <ludo@gnu.org>2015-09-17 11:21:42 +0200
commit2d1db448bdbce9cd8a6df39097f56c3840754949 (patch)
tree81408dc9b6fd7074d6b015882c6816b9e8db927d /gnu/packages
parentd001bb5ab54b4e174392be6137e7acaec1e6f0f3 (diff)
downloadguix-2d1db448bdbce9cd8a6df39097f56c3840754949.tar.gz
guix-2d1db448bdbce9cd8a6df39097f56c3840754949.zip
gnu: Add emacs-typo.
* gnu/packages/emacs.scm (typo): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index cdd73206c4..a342f4861b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1148,3 +1148,27 @@ integration servers. Users can specify a list of server in the
view the build status of those servers' build jobs, and possibly to trigger
build jobs.")
(license license:gpl3+)))
+
+(define-public typo
+ (package
+ (name "emacs-typo")
+ (version "1.1")
+ (home-page "https://github.com/jorgenschaefer/typoel")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "1jhd4grch5iz12gyxwfbsgh4dmz5hj4bg4gnvphccg8dsnni05k2"))
+ (file-name (string-append name "-" version))))
+ (build-system emacs-build-system)
+ (synopsis "Minor mode for typographic editing")
+ (description
+ "This package provides two Emacs modes, @code{typo-mode} and
+@code{typo-global-mode}. These modes automatically insert Unicode characters
+for quotation marks, dashes, and ellipses. For example, typing @kbd{\"}
+automatically inserts a Unicode opening or closing quotation mark, depending
+on context.")
+ (license license:gpl3+)))
ns.scm?id=e379d1b5efad293951fd35920bbf142376058696'>gnu: dns: Fix configuration formating.Julien Lepiller * gnu/services/dns.scm (format-string-list): Fix formating of lists with only one symbol. 2019-04-25gnu: knot-service: Add includes field in configuration.Julien Lepiller * gnu/services/dns.scm (knot-configuration): Add includes field. (verify-knot-configuration): Check includes content. (knot-config-file): Serialize includes. * doc/guix.texi (DNS Services): Document it. 2018-12-04services: ddclient: Fix unrecognized keywords.Oleg Pykhalov This patch fixes warnings about unrecognized keywords in logs. * gnu/services/dns.scm (serialize-field): Skip some field names. 2018-11-06gnu: services: dns: Fix 'ddclient-activation'.Oleg Pykhalov * gnu/services/dns.scm (ddclient-activation): Fix procedure. 2018-08-30services: Add ddclient service.Oleg Pykhalov * gnu/services/dns.scm (ddclient-configuration, ddclient-service-type): New variables. (uglify-field-name, serialize-field, serialize-boolean, serialize-integer, serialize-string, serialize-list, serialize-extra-options, ddclient-activation, ddclient-shepherd-service, generate-ddclient-documentation): New procedures. * doc/guix.texi (DNS Services): Document it. 2018-06-08services: dnsmasq-service-type: Add default configuration and description.宋文武 * gnu/services/dns.scm (dnsmasq-service-type) [default-value, description]: New fields. 2018-06-08services: dnsmasq: Use 'negative-cache?' instead of 'no-negcache?'.宋文武 The 'no-negcache?' option is mapped to the '--no-negcache' command-line argument directly, but we're in the scheme world, where the general guideline is to avoid double-negations in identifiers. * gnu/services/dns.scm <dnsmasq-configuration>: Replace the 'no-negcache?' field with 'negative-cache?'. * doc/guix.texi (DNS Services)[Dnsmasq Service]: Adjust accordingly. 2018-06-05services: Add dnsmasq-service-type.宋文武 * gnu/services/dns.scm (dnsmasq-service-type): New variable. (<dnsmasq-configuration>): New record type. (dnsmasq-shepherd-service): New procedure. * doc/guix.texi (DNS Services): Document it. 2017-06-21gnu: services: use seconds instead of duration strings.Julien Lepiller * gnu/services/dns.scm (zone-file, knot-policy-configuration): Use numbers instead of duration strings. (verify-knot-policy-configuration): Fix typo. * doc/guix.texi (DNS Services): Update documentation. 2017-05-27gnu: Add knot-service-type.Julien Lepiller * gnu/services/dns.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * doc/guix.texi (DNS Services): New subsubsection.