aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-22 09:43:16 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-22 09:49:27 +0300
commit285e18e9ae45970c67ec3b35d1d589bed32089f8 (patch)
tree92677edc6a6f72a22278780ec9d7971a7fb306c8 /gnu/packages
parent61b31ac46f9e8a36fc0862941f8dd1f203f8c8ba (diff)
downloadguix-285e18e9ae45970c67ec3b35d1d589bed32089f8.tar.gz
guix-285e18e9ae45970c67ec3b35d1d589bed32089f8.zip
gnu: terminology: Update to 1.1.0.
* gnu/packages/enlightenment.scm (terminology): Update to 1.1.0. [source]: Remove bundled fonts and references to them. [native-inputs]: Add gettext-minimal.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/enlightenment.scm23
1 files changed, 20 insertions, 3 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index da1a1cf43d..8c25f38aae 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -165,7 +165,7 @@ removable devices or support for multimedia.")
(define-public terminology
(package
(name "terminology")
- (version "1.0.0")
+ (version "1.1.0")
(source (origin
(method url-fetch)
(uri
@@ -173,7 +173,23 @@ removable devices or support for multimedia.")
"terminology/terminology-" version ".tar.xz"))
(sha256
(base32
- "1x4j2q4qqj10ckbka0zaq2r2zm66ff1x791kp8slv1ff7fw45vdz"))))
+ "13rl1k22yf8qrpzdm5nh6ij641fibadr2ww1r7rnz7mbhzj3d4gb"))
+ (modules '((guix build utils)))
+ ;; Remove the bundled fonts.
+ ;; TODO: Remove bundled lz4.
+ (snippet
+ '(begin
+ (delete-file-recursively "data/fonts")
+ (substitute* '("data/Makefile.in" "data/Makefile.am")
+ (("fonts") ""))
+ (substitute* "configure"
+ (("data/fonts/Makefile") "")
+ (("\\\"data/fonts/Makefile") "# \"data/fonts/Makefile"))
+ (substitute* '("data/themes/Makefile.in"
+ "data/themes/Makefile.am"
+ "data/themes/nyanology/Makefile.in"
+ "data/themes/nyanology/Makefile.am")
+ (("-fd \\$\\(top_srcdir\\)/data/fonts") ""))))))
(build-system gnu-build-system)
(arguments
'(#:phases
@@ -182,7 +198,8 @@ removable devices or support for multimedia.")
;; FATAL: Cannot create run dir '/homeless-shelter/.run' - errno=2
(lambda _ (setenv "HOME" "/tmp") #t)))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("gettext" ,gettext-minimal)
+ ("pkg-config" ,pkg-config)))
(inputs
`(("efl" ,efl)))
(home-page "https://www.enlightenment.org/about-terminology")
colspan='3' class='logmsg'> * gnu/services/dns.scm (%kresd.conf): Add /var/cache/knot-resolver/root.keys as the root TA. 2020-01-21services: sane: Create the "scanner" account.Ludovic Courtès * gnu/services/desktop.scm (%sane-accounts, sane-service-type): New variables. (%desktop-services): Use SANE-SERVICE-TYPE instead of 'simple-service'. * doc/guix.texi (Desktop Services): Document 'sane-service-type'. 2020-01-20services: getmail: Adjust a couple of default configuration values.Christopher Baines Change the message-log-syslog and message-log-verbose configuration values to match the Getmail defaults. * gnu/services/getmail.scm (getmail-options-configuration): Change defaults for message-log-syslog and message-log-verbose * doc/guix.texi (Mail Services): Update the Getmail documentation accordingly. 2020-01-20services: getmail: Fix some configuration documentation strings.Christopher Baines * gnu/services/getmail.scm (getmail-retriever-configuration): Specify proper documentation strings for some of the fields. * doc/guix.texi (Mail Services): Update the documentation accordingly. 2020-01-20services: getmail: Fix stopping the shepherd service.Christopher Baines * gnu/services/getmail.scm (getmail-shepherd-services): Add a stop component to the shepherd services. 2020-01-20services: Add "sane" service.Danny Milosavljevic * gnu/services/desktop.scm (%desktop-services): Add "sane" service. 2020-01-19gnu: Use HTTPS for avahi.org everywhere.Tobias Geerinckx-Rice * gnu/packages/avahi.scm (avahi)[home-page]: Use HTTPS. * gnu/services/avahi.scm (avahi-service): Likewise in docstring. 2020-01-17gnu: services: Allow extra content in mysql configuration.Alex Sassmannshausen * gnu/services/databases.scm (<mysql-configuration>): New field. (mysql-configuration-file): Use it.