aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 10:14:13 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:09 -0500
commit28049c2ac89bfd70410b593d5bb8ca121fa699e5 (patch)
tree82ae5fec124365ba34e08f0ad7192991bf3715f0 /gnu/packages
parent86a704dbc5eb80750e348ef59252dbee3a87f08e (diff)
downloadguix-28049c2ac89bfd70410b593d5bb8ca121fa699e5.tar.gz
guix-28049c2ac89bfd70410b593d5bb8ca121fa699e5.zip
gnu: ghc-tasty: Update to 1.2.3.
* gnu/packages/haskell-check.scm (ghc-tasty): Update to 1.2.3.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell-check.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index c7f1afdbc4..2ae02cda61 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -156,7 +156,7 @@ contains the correct result for the test.")
(define-public ghc-tasty
(package
(name "ghc-tasty")
- (version "1.1.0.3")
+ (version "1.2.3")
(source
(origin
(method url-fetch)
@@ -166,7 +166,7 @@ contains the correct result for the test.")
".tar.gz"))
(sha256
(base32
- "14riid753hjqr6lca1kgxpnvq0wykf0k3qc5jpag42hh8bszav22"))))
+ "0qpn0avpw4w1qq5r2gwh2piipj0llqq6ylagr3xnqiraq6mhg8cc"))))
(build-system haskell-build-system)
(inputs
`(("ghc-tagged" ,ghc-tagged)
(version>? new-version old-version) (cons package new-version))) (_ #f)))) new)) (noteworthy (filter (match-lambda ((package . version) (member package important))) upgraded))) (with-atomic-file-replacement news-file (lambda (input output) (rewrite-org-section input output (make-regexp "^(\\*+).*package updates") (lambda (match port) (let ((stars (match:substring match 1)) (lst (map (match-lambda ((package . version) (string-append package " " version))) noteworthy))) (format port "~a ~a package updates~%~%Noteworthy updates:~%~a~%~%" stars (length upgraded) (enumeration->paragraph lst))))))))) (define (main . args) (match args ((news-file data-directory) ;; Don't browse things listed in the user's $GUIX_PACKAGE_PATH and ;; in external channels. (parameterize ((%package-module-path %default-package-module-path)) (define (package-file version) (string-append data-directory "/packages-" version ".txt")) (define (package<? p1 p2) (string<? (package-full-name p1) (package-full-name p2))) (let-values (((previous-version new-version) (call-with-input-file news-file NEWS->versions))) (format (current-error-port) "Updating NEWS for ~a to ~a...~%" previous-version new-version) (let* ((old (call-with-input-file (package-file previous-version) read)) (all-packages/sorted (sort (fold-packages (lambda (p r) (cons p r)) '()) package<?)) (new (map (lambda (p) (cons (package-name p) (package-version p))) all-packages/sorted))) (call-with-output-file (package-file new-version) (lambda (port) (pretty-print new port))) (write-packages-added news-file old new) (write-packages-updates news-file old new))))) (x (format (current-error-port) "Usage: update-NEWS NEWS-FILE DATA-DIRECTORY Update the list of new and updated packages in NEWS-FILE using the previous-version package list from DATA-DIRECTORY.\n") (exit 1)))) (apply main (cdr (command-line)))