aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 21:18:48 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit27e7c8b6a6c3a49ac8f734232c9e7f4407937a46 (patch)
treed6a5c9ef7544c5c85e39357f61f690979ef92916 /gnu/packages
parent85160205074a3213cfd3168b786a2af5555f13a8 (diff)
downloadguix-27e7c8b6a6c3a49ac8f734232c9e7f4407937a46.tar.gz
guix-27e7c8b6a6c3a49ac8f734232c9e7f4407937a46.zip
gnu: Add ghc-byteorder.
* gnu/packages/haskell.scm (ghc-byteorder): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 717eef0a12..7c07ff2dea 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1928,6 +1928,30 @@ a subset of @code{MonadBase} into which generic control operations such as
@code{catch} can be lifted from @code{IO} or any other base monad.")
(license bsd-3)))
+(define-public ghc-byteorder
+ (package
+ (name "ghc-byteorder")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/byteorder/byteorder-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "06995paxbxk8lldvarqpb3ygcjbg4v8dk4scib1rjzwlhssvn85x"))))
+ (build-system haskell-build-system)
+ (home-page
+ "http://community.haskell.org/~aslatter/code/byteorder")
+ (synopsis
+ "Exposes the native endianness of the system")
+ (description
+ "This package is for working with the native byte-ordering of the
+system.")
+ (license bsd-3)))
+
(define-public ghc-async
(package
(name "ghc-async")
span title='2020-10-30 01:14:20 +0100'>2020-10-30file-systems: Allow swap space lookup by UUID/label....Ludovic Courtès 2020-10-14hurd-boot: Set /hurd/magic on /dev/fd....Ludovic Courtès 2020-10-08hurd-boot: Create /servers/crash....Ludovic Courtès 2020-10-05bootloader: Fix u-boot installation....Mathieu Othacehe 2020-10-01linux-container: Reset jailed root permissions....Jelle Licht 2020-09-29secret-service: Add proper logging procedure and log to syslog....Ludovic Courtès 2020-09-29services: secret-service: Add initial client/server handshake....Ludovic Courtès 2020-09-29secret-service: Fix file port leak in 'secret-service-send-secrets'....Ludovic Courtès 2020-09-29secret-service: Add a timeout when waiting for a client....Ludovic Courtès 2020-09-29secret-service: Clarify the origin of messages....Ludovic Courtès 2020-09-29image: Add support for compressed-qcow2 format....Mathieu Othacehe 2020-09-21build: shepherd: Check for container support....Mathieu Othacehe 2020-09-10build: linux-container: Fix run-container....Mathieu Othacehe 2020-09-07linux-boot: Handle nfs-root device strings....Stefan 2020-09-02installer: Run the installation inside a container....Mathieu Othacehe 2020-09-02linux-container: Do not jail the container unconditionally....Mathieu Othacehe 2020-09-02install: Factorize cow-store procedure....Mathieu Othacehe 2020-09-01services: Add secret-service-type....Jan (janneke) Nieuwenhuizen 2020-08-25linux-libre: Support module compression....Mathieu Othacehe 2020-07-31file-system: Add mount-may-fail? option....Mathieu Othacehe 2020-07-26file-systems: Add NTFS support....Mathieu Othacehe 2020-07-11image: Do not set journal_model=WAL for the Hurd....Jan (janneke) Nieuwenhuizen