aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-04 02:01:22 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-04 09:39:12 +0100
commit26b7d23aa6e67955f74cb5bcfe33b6f222c9df83 (patch)
tree1099e291f7f24e099baeeafbae65b5f86742e948 /gnu/packages
parent17d25019fd5d95cb7555b518ddfb869d7308ed73 (diff)
downloadguix-26b7d23aa6e67955f74cb5bcfe33b6f222c9df83.tar.gz
guix-26b7d23aa6e67955f74cb5bcfe33b6f222c9df83.zip
gnu: containerd: Update to 1.2.2.
* gnu/packages/docker.scm (containerd): Update to 1.2.2.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/docker.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 18df9a470b..cb7c16d440 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -160,7 +161,7 @@ Python without keeping their credentials in a Docker configuration file.")
(define-public containerd
(package
(name "containerd")
- (version "1.2.1")
+ (version "1.2.2")
(source
(origin
(method git-fetch)
@@ -170,7 +171,7 @@ Python without keeping their credentials in a Docker configuration file.")
(file-name (git-file-name name version))
(sha256
(base32
- "16zn6p1ky3yrgn53z8h9wza53ch91fj47wj5xgz6w4c57j30f66p"))))
+ "065snv0s3v3z0ghadlii4w78qnhchcbx2kfdrvm8fk8gb4pkx1ya"))))
(build-system go-build-system)
(arguments
`(#:import-path "github.com/containerd/containerd"
ndent name to allow for parallel builds. Note # that the directory name must be chosen so that the socket's file # name is less than 108-char long (the size of `sun_path' in glibc). # Currently, in Nix builds, we're at ~106 chars... NIX_STATE_DIR="@GUIX_TEST_ROOT@/var/$$" # We can't exit when we reach the limit, because perhaps the test doesn't # actually rely on the daemon, but at least warn. if test "`echo -n "$NIX_STATE_DIR/daemon-socket/socket" | wc -c`" -ge 108 then echo "warning: exceeding socket file name limit; test may fail!" >&2 fi # The configuration directory, for import/export signing keys. NIX_CONF_DIR="@GUIX_TEST_ROOT@/etc" if [ ! -d "$NIX_CONF_DIR" ] then # Copy the keys so that the secret key has the right permissions (the # daemon errors out when this is not the case.) mkdir -p "$NIX_CONF_DIR" cp "@abs_top_srcdir@/tests/signing-key.sec" \ "@abs_top_srcdir@/tests/signing-key.pub" \ "$NIX_CONF_DIR" chmod 400 "$NIX_CONF_DIR/signing-key.sec" fi # A place to store data of the substituter. GUIX_BINARY_SUBSTITUTE_URL="file://$NIX_STATE_DIR/substituter-data" rm -rf "$NIX_STATE_DIR/substituter-data" mkdir -p "$NIX_STATE_DIR/substituter-data" # For a number of tests, we want to allow unsigned narinfos, for # simplicity. GUIX_ALLOW_UNAUTHENTICATED_SUBSTITUTES=yes # Place for the substituter's cache. XDG_CACHE_HOME="$NIX_STATE_DIR/cache-$$" # For the (guix import snix) tests. NIXPKGS="@NIXPKGS@" export NIX_IGNORE_SYMLINK_STORE NIX_STORE_DIR \ NIX_LOCALSTATE_DIR NIX_LOG_DIR NIX_STATE_DIR NIX_DB_DIR \ NIX_ROOT_FINDER GUIX_BINARY_SUBSTITUTE_URL \ GUIX_ALLOW_UNAUTHENTICATED_SUBSTITUTES \ NIX_CONF_DIR XDG_CACHE_HOME NIXPKGS # Launch the daemon without chroot support because is may be # unavailable, for instance if we're not running as root. "@abs_top_builddir@/pre-inst-env" \ "@abs_top_builddir@/guix-daemon" --disable-chroot \ --substitute-urls="$GUIX_BINARY_SUBSTITUTE_URL" & daemon_pid=$! trap "kill $daemon_pid ; rm -rf $NIX_STATE_DIR" EXIT fi # Avoid issues that could stem from l10n, such as language/encoding # mismatches. unset LANGUAGE LC_MESSAGES=C export LC_MESSAGES # Disable grafts by default because they can cause things to be built # regardless of '--dry-run'. GUIX_BUILD_OPTIONS="--no-grafts" export GUIX_BUILD_OPTIONS # Ignore user settings. unset GUIX_PACKAGE_PATH storedir="@storedir@" prefix="@prefix@" datarootdir="@datarootdir@" datadir="@datadir@" localstatedir="@localstatedir@" export storedir prefix datarootdir datadir localstatedir "@abs_top_builddir@/pre-inst-env" "$@" exit $?