aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2024-10-25 23:35:47 +0200
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-10-26 22:34:07 +0300
commit269e4034fcaf55324187efffb6ed5ba14d5e9286 (patch)
treebaee76cc15326d55fde5bddbeacada86dea92cc6 /gnu/packages
parent45e08bc7d99b9b7a1958ee3d588a5c09f5c7d851 (diff)
downloadguix-269e4034fcaf55324187efffb6ed5ba14d5e9286.tar.gz
guix-269e4034fcaf55324187efffb6ed5ba14d5e9286.zip
gnu: yoshimi: Fix build.
yoshimi was failing because it was trying to create a directory inside the lv2 store tree. * gnu/packages/music.scm (yoshimi)[arguments]<configure-flags>: Explicitly set LV2_INSTALL_DIR. Change-Id: I697ba879e8633bee99fdfad1e876beca33d114f8 Signed-off-by: Artyom V. Poptsov <poptsov.artyom@gmail.com>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/music.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 049e6e1676..724dfb52f5 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2019, 2020, 2021 Alexandros Theodotou <alex@zrythm.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020 Lars-Dominik Braun <lars@6xq.net>
-;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020, 2024 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2020, 2022, 2023 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
@@ -3461,7 +3461,9 @@ capabilities, custom envelopes, effects, etc.")
(list
#:tests? #f ; there are no tests
#:configure-flags
- #~(list (string-append "-DCMAKE_INSTALL_DATAROOTDIR="
+ #~(list (string-append "-DLV2_INSTALL_DIR="
+ #$output "/lib/lv2")
+ (string-append "-DCMAKE_INSTALL_DATAROOTDIR="
#$output "/share"))
#:phases
#~(modify-phases %standard-phases