aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 20:42:57 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:35 +0200
commit26944757fbc8057c832380ed0c498b014d100bd2 (patch)
tree715f8af96cafce4193e0b1ac14f5b9ab234add2d /gnu/packages
parentdbe43a3fbf820ebb4f872b1fd421168863bee65a (diff)
downloadguix-26944757fbc8057c832380ed0c498b014d100bd2.tar.gz
guix-26944757fbc8057c832380ed0c498b014d100bd2.zip
gnu: texlive-logreq: Refresh package definition.
* gnu/packages/tex.scm (texlive-logreq): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-ETOOLBOX, TEXLIVE-GRAPHICS.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm56
1 files changed, 26 insertions, 30 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0af4aba79a..2f11f2df9b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10768,36 +10768,32 @@ styles as well as the optional active quotes are freely configurable.")
(license license:lppl1.3c+))))
(define-public texlive-logreq
- (let ((template (simple-texlive-package
- "texlive-logreq"
- (list "/doc/latex/logreq/"
- "/tex/latex/logreq/")
- (base32
- "13difccs3cxlkqlnhw286yb0c7mifrxfd402a2x5wwxv0m1kgfqd")
- #:trivial? #t)))
- (package
- (inherit template)
- (propagated-inputs
- (list texlive-etoolbox))
- (home-page "https://www.ctan.org/pkg/logreq")
- (synopsis "Support for automation of the LaTeX workflow")
- (description "The package helps to automate a typical LaTeX
-workflow that involves running LaTeX several times and running tools
-such as BibTeX or makeindex. It will log requests like \"please rerun
-LaTeX\" or \"please run BibTeX on file X\" to an external file in a
-machine-readable format. Compiler scripts and integrated LaTeX
-editing environments may parse this file to determine the next steps
-in the workflow. In sum, the package will do two things:
-
-@enumerate
-@item
-enable package authors to use LaTeX commands to issue requests, and
-
-@item
-collect all requests from all packages and write them to an external
-XML file.
-@end enumerate\n")
- (license license:lppl1.3c))))
+ (package
+ (name "texlive-logreq")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/logreq/" "tex/latex/logreq/")
+ (base32
+ "13difccs3cxlkqlnhw286yb0c7mifrxfd402a2x5wwxv0m1kgfqd")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-etoolbox
+ texlive-graphics))
+ (home-page "https://ctan.org/pkg/logreq")
+ (synopsis "Support for automation of the LaTeX workflow")
+ (description
+ "The package helps to automate a typical LaTeX workflow that involves
+running LaTeX several times, running tools such as BibTeX or makeindex, and so
+on. It will log requests like ``please rerun LaTeX'' or ``please run BibTeX
+on file X'' to an external XML file which lists all open tasks in
+a machine-readable format. Compiler scripts and integrated LaTeX editing
+environments may parse this file to determine the next steps in the
+workflow. In sum, the package will do two things: enable package authors to
+use LaTeX commands to issue requests, collect all requests from all packages
+and write them to an external XML file at the end of the document.")
+ (license license:lppl1.3+)))
(define-public texlive-biblatex
(package