aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 21:25:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-30 10:30:45 +0100
commit234bcc8fd6123a420b060390651e34b6befbc093 (patch)
tree9e3d0676b4f5a0f5e187434f74c57923c6281db7 /gnu/packages
parentb5de40f04b85b43c5302f274362dda026694521b (diff)
downloadguix-234bcc8fd6123a420b060390651e34b6befbc093.tar.gz
guix-234bcc8fd6123a420b060390651e34b6befbc093.zip
gnu: skymaker: Update to 3.10.5.
* gnu/packages/astronomy.scm (skymaker): Update to 3.10.5. Change-Id: Ib66f35834bdf3d6ce7d1b6924415a3e49b3ae7f9
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/astronomy.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index bbffe744ab..ae2593e8e4 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1467,27 +1467,24 @@ interactively in the plotting window.")
(license license:gpl2+)))
(define-public skymaker
- ;; XXX: No version tag available in GitHub.
- ;; See: https://github.com/astromatic/skymaker/issues/3
- (let ((commit "1a69c4716bdc9b5c6d4a917b0bc2dbd47635c459")
- (revision "0"))
(package
(name "skymaker")
- (version (git-version "4.2.0" revision commit))
+ (version "3.10.5")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/astromatic/skymaker")
- (commit commit)))
+ (commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1vin4vgvcmqmwjdchsxnap374559rksz55xmaliawnl3qpzxn1nk"))))
+ (base32 "0kcy0lfm25gihahpr41ghhw3b8znzczzg9rrlkfih043h2pfsm5l"))))
(build-system gnu-build-system)
(arguments
(list
#:configure-flags
#~(list
+ "CPPFLAGS=-fcommon"
(string-append
"--with-fftw-libdir=" #$(this-package-input "fftwf") "/lib")
(string-append
@@ -1503,7 +1500,7 @@ interactively in the plotting window.")
object lists in ASCII generated by the Stuff program to produce realistic
astronomical fields. SkyMaker is part of the
@uref{https://www.astromatic.net/projects/efigi, EFIGI} development project.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public stackistry
(package