aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-07-01 15:34:29 -0300
committerVinicius Monego <monego@posteo.net>2024-07-28 10:59:04 -0300
commit22e8880ae2bf991f09386074b10bdf8ac2dcf50a (patch)
tree4d292b16f202b6593ce367fd00987c008079c2fb /gnu/packages
parent2b40c6985a74a2ef95d2b3d59a64769dd2ac1469 (diff)
downloadguix-22e8880ae2bf991f09386074b10bdf8ac2dcf50a.tar.gz
guix-22e8880ae2bf991f09386074b10bdf8ac2dcf50a.zip
gnu: python-pyro-ppl: Update to 1.9.1.
* gnu/packages/machine-learning.scm (python-pyro-ppl): Update to 1.9.1. [arguments]: Remove #:test-flags and skip all tests in #:tests?. Change-Id: If90024d904bb830df2868423a5947ecaf45b46fc
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/machine-learning.scm22
1 files changed, 5 insertions, 17 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index d3fe98f293..69855ed02a 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -5484,7 +5484,7 @@ and Numpy.")
(define-public python-pyro-ppl
(package
(name "python-pyro-ppl")
- (version "1.8.6")
+ (version "1.9.1")
;; The sources on pypi don't include tests.
(source
(origin
@@ -5494,24 +5494,12 @@ and Numpy.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0n1vsih99pvswcaygdxkc6kq6r48ny130z6ca8pp3281396r2ykw"))))
+ (base32 "0q87d0frgzn1ljnpbyxmj582yfn6zy3m960m3ab826h4rpzybxhf"))))
(build-system pyproject-build-system)
(arguments
- (list
- #:test-flags
- '(list "-vv" "--stage=unit"
- ;; This tests features that are only implemented when non-free
- ;; software is available (Intel MKL or CUDA).
- "--ignore=tests/distributions/test_spanning_tree.py"
- "--ignore=tests/infer/mcmc/test_mcmc_api.py"
- ;; This test fails sometimes.
- "--ignore=tests/optim/test_optim.py"
- ;; Four test_gamma_elbo tests fail with bad values for unknown
- ;; reasons.
- "--ignore=tests/distributions/test_rejector.py"
- ;; This looks like a test system failure. All of these fail
- ;; because x is an array of functions, not an array of numbers.
- "-k" "not test_sample")))
+ ;; Tests take too long.
+ ;; XXX: Maybe select the most important test modules.
+ (list #:tests? #f))
(propagated-inputs
(list python-numpy
python-opt-einsum