aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-08-04 22:15:41 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-06 11:46:23 +0200
commit2225a6a4d02641e7c440b1aa726db5bd9f1e39b3 (patch)
tree252952c4913039b7bd2ff51c7b154dec71eb8ccd /gnu/packages
parent459062ba3c60b561bb65c64d54983a72bb8ad50b (diff)
downloadguix-2225a6a4d02641e7c440b1aa726db5bd9f1e39b3.tar.gz
guix-2225a6a4d02641e7c440b1aa726db5bd9f1e39b3.zip
gnu: python-optree: Update to 0.11.0.
* gnu/packages/python-xyz.scm (python-optree): Update to 0.11.0. [arguments]<#:test-flags>: Disable failing test.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 16424749bb..21e04e75e9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12311,7 +12311,7 @@ without using the configuration machinery.")
(define-public python-optree
(package
(name "python-optree")
- (version "0.10.0")
+ (version "0.11.0")
(source
(origin
(method git-fetch)
@@ -12321,9 +12321,14 @@ without using the configuration machinery.")
(file-name (git-file-name name version))
(sha256
(base32
- "1q3wljk7cyl5rsam02sfsj8zjrqx4c3x9vic8j6xx13p8czpsisg"))
+ "0sk5lm1xyxi7z0yjckip77qvbidyb7i1znmn9fz96q74hl9ffyan"))
(patches (search-patches "python-optree-fix-32-bit.patch"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ ;; This test fails due to a circular import
+ ''("-k" "not test_treespec_pickle_missing_registration")))
(propagated-inputs (list python-typing-extensions))
(native-inputs
(list python-pytest