<
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:13:19 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:36 +0200
commit21b1845ddeb33624140711260029d166d1f20b07 (patch)
treee1e1b4e9dca3fd0df9fbff6e3a3cd407728d1f08 /gnu/packages
parent07c3711d0fdaae8cdd3e6a466b48b98add251918 (diff)
downloadguix-21b1845ddeb33624140711260029d166d1f20b07.tar.gz
guix-21b1845ddeb33624140711260029d166d1f20b07.zip
gnu: ocaml4.02-ezjsonm: Don't use unstable tarball.
* gnu/packages/ocaml.scm (ocaml4.02-ezjsonm)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index f341039461..3b44e7e9f2 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3945,14 +3945,15 @@ writing to these structures, and they are accessed via the Bigarray module.")
(package
(name "ocaml4.02-ezjsonm")
(version "0.4.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mirage/ezjsonm/archive/"
- version ".tar.gz"))
- (sha256
- (base32
- "1kag0z2xlk4rw73a240dmkxh9rj6psxxcxkm7d7z0rrj6hzjajgq"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mirage/ezjsonm.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1y6p3ga6vj1wx5dyns7hjgd0qgrrn2hnn323a7y5didgci5pybls"))))
(build-system ocaml-build-system)
(native-inputs
`(("alcotest" ,ocaml4.02-alcotest)))
(start #~(make-forkexec-constructor (list #$(marionette-program device imported-modules extensions)))) (stop #~(make-kill-destructor))))))) (define marionette-service-type ;; This is the type of the "marionette" service, allowing a guest system to ;; be manipulated from the host. This marionette REPL is essentially a ;; universal backdoor. (service-type (name 'marionette-repl) (extensions (list (service-extension shepherd-root-service-type marionette-shepherd-service))) (description "The @dfn{marionette} service allows a guest system (virtual machine) to be manipulated by the host. It is used for system tests."))) (define* (marionette-operating-system os #:key (imported-modules '()) (extensions '()) (requirements '())) "Return a marionetteed variant of OS such that OS can be used as a marionette in a virtual machine--i.e., controlled from the host system. The marionette service in the guest is started after the Shepherd services listed in REQUIREMENTS. The packages in the list EXTENSIONS are made available from the backdoor REPL." (operating-system (inherit os) ;; Make sure the guest dies on error. (kernel-arguments (cons "panic=1" (operating-system-user-kernel-arguments os))) ;; Make sure the guest doesn't hang in the REPL on error. (initrd (lambda (fs . rest) (apply (operating-system-initrd os) fs #:on-error 'backtrace rest))) (services (cons (service marionette-service-type (marionette-configuration (requirements requirements) (extensions extensions) (imported-modules imported-modules))) (operating-system-user-services os))))) (define-syntax define-os-with-source (syntax-rules (use-modules operating-system) "Define two variables: OS containing the given operating system, and SOURCE containing the source to define OS as an sexp. This is convenient when we need both the <operating-system> object so we can instantiate it, and the source to create it so we can store in in a file in the system under test." ((_ (os source) (use-modules modules ...) (operating-system fields ...)) (begin (define os (operating-system fields ...)) (define source '(begin (use-modules modules ...) (operating-system fields ...))))))) ;;; ;;; Simple operating systems. ;;; (define %simple-os (operating-system (host-name "komputilo") (timezone "Europe/Berlin") (locale "en_US.UTF-8") (bootloader (bootloader-configuration (bootloader grub-bootloader) (targets '("/dev/sdX")))) (file-systems (cons (file-system (device (file-system-label "my-root")) (mount-point "/") (type "ext4")) %base-file-systems)) (firmware '()) (users (cons (user-account (name "alice") (comment "Bob's sister") (group "users") (supplementary-groups '("wheel" "audio" "video"))) %base-user-accounts)))) (define-syntax-rule (simple-operating-system user-services ...) "Return an operating system that includes USER-SERVICES in addition to %BASE-SERVICES." (operating-system (inherit %simple-os) (services (cons* user-services ... %base-services)))) ;;; ;;; Tests. ;;; (define-record-type* <system-test> system-test make-system-test system-test? (name system-test-name) ;string (value system-test-value) ;%STORE-MONAD value (description system-test-description) ;string (location system-test-location (innate) ;<location> (default (and=> (current-source-location) source-properties->location)))) (define (write-system-test test port) (match test (($ <system-test> name _ _ ($ <location> file line)) (format port "#<system-test ~a ~a:~a ~a>" name file line (number->string (object-address test) 16))) (($ <system-test> name) (format port "#<system-test ~a ~a>" name (number->string (object-address test) 16))))) (set-record-type-printer! <system-test> write-system-test) (define-gexp-compiler (compile-system-test (test <system-test>) system target) "Compile TEST to a derivation." (mparameterize %store-monad ((%current-system system) (%current-target-system target)) (system-test-value test))) (define (test-modules) "Return the list of modules that define system tests." (scheme-modules (dirname (search-path %load-path "guix.scm")) "gnu/tests" #:warn warn-about-load-error)) (define (fold-system-tests proc seed) "Invoke PROC on each system test, passing it the test and the previous result." (fold-module-public-variables (lambda (obj result) (if (system-test? obj) (cons obj result) result)) '() (test-modules))) (define (all-system-tests) "Return the list of system tests." (reverse (fold-system-tests cons '()))) ;; Local Variables: ;; eval: (put 'with-imported-modules-and-extensions 'scheme-indent-function 2) ;; End: ;;; tests.scm ends here