aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 16:10:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:09 +0200
commit2189b941be1149cfa8645b9368c65c513ebe34f6 (patch)
tree0324e2ceae5d78c5da6ba8a49e3909de813da3ea /gnu/packages
parent89193c050c19d56b0782afc11eba5895e7b9f52d (diff)
downloadguix-2189b941be1149cfa8645b9368c65c513ebe34f6.tar.gz
guix-2189b941be1149cfa8645b9368c65c513ebe34f6.zip
gnu: Add texlive-index.
* gnu/packages/tex.scm (texlive-index): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dd4033e6e3..8c757c0695 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1008,6 +1008,27 @@ article into an exceptions file, together with a recent copy of the article
and machine-readable files.")
(license license:public-domain)))
+(define-public texlive-index
+ (package
+ (name "texlive-index")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/index/" "doc/latex/index/"
+ "makeindex/index/" "source/latex/index/"
+ "tex/latex/index/")
+ (base32
+ "0f1infc8fcpw16crciampy4cqqhl4hzypyfacbwsk4cnl0fyivns")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/index")
+ (synopsis "Extended index for LaTeX including multiple indexes")
+ (description
+ "This is a reimplementation of LaTeX's indexing macros to provide better
+support for indexing. For example, it supports multiple indexes in a single
+document and provides a more robust @code{\\index} command.")
+ (license license:lppl1.2+))) ;from "index.dtx"
+
(define-public texlive-dvipdfmx
(package
(name "texlive-dvipdfmx")