aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRodion Goritskov <rodion.goritskov@gmail.com>2024-07-03 23:22:31 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-11 12:34:27 +0100
commit1ff5daf53b134fef0d3c35944f7106d0aa7db0c7 (patch)
treec9851d497663aaf060cfdd8a41a54a78a1f9a158 /gnu/packages
parent07a814fdcfef39becbc105e2a849e551a65a2e16 (diff)
downloadguix-1ff5daf53b134fef0d3c35944f7106d0aa7db0c7.tar.gz
guix-1ff5daf53b134fef0d3c35944f7106d0aa7db0c7.zip
gnu: Add go-github-com-abadojack-whatlanggo.
* gnu/packages/golang-xyz.scm (go-github-com-abadojack-whatlanggo): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I49a0d5c9d97ba9eb1279b75f5177966e800a2475
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ee2585c68d..f7e40550ff 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -373,6 +373,31 @@ Golang.")
substitution.")
(license license:expat)))
+(define-public go-github-com-abadojack-whatlanggo
+ (package
+ (name "go-github-com-abadojack-whatlanggo")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abadojack/whatlanggo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pidd5dqvcnqjjka12h0clj3mmq0j3bpanf9153schsx85xz7mzx"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/abadojack/whatlanggo"))
+ (home-page "https://github.com/abadojack/whatlanggo")
+ (synopsis "Natural language detection library for Golang")
+ (description
+ "This package provides functionality for detecting natural languages and
+scripts (writing systems). Languages are represented by a defined list of
+constants, while scripts are represented by RangeTable.")
+ (license license:expat)))
+
(define-public go-github-com-adrg-strutil
(package
(name "go-github-com-adrg-strutil")