aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-08-30 10:57:28 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:48 +0200
commit1fd059a14af5db6699be636667ff1ba730763065 (patch)
treeebcbde7d436b55b040e90b3c952b5e2bff702711 /gnu/packages
parentc42707fcc3c90a698e9d3e7c852527ddf691e6fb (diff)
downloadguix-1fd059a14af5db6699be636667ff1ba730763065.tar.gz
guix-1fd059a14af5db6699be636667ff1ba730763065.zip
gnu: libcamera: Do not pass empty string to meson.
* gnu/packages/networking.scm (libcamera)[arguments]: Use list for extra arguments to meson to avoid passing an empty string. Change-Id: I5e494eb10f06b4fe9e65e3b0f0f32dd99947b250
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/networking.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 9391b9f704..beb5f378b9 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2017, 2018, 2021 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2020 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2016, 2017, 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016 Raimon Grau <raimonster@gmail.com>
@@ -397,9 +397,9 @@ them in order to efficiently transfer a minimal amount of data.")
;; In 0.3.1 release simple pipeline wasn't enabled for
;; x86_64 by mistake, it's enabled a couple commits later.
;; Remove this expression on the next release.
- #$(if (target-x86-64?)
- "-Dpipelines=ipu3,vimc,uvcvideo,simple"
- "")
+ #$@(if (target-x86-64?)
+ '("-Dpipelines=ipu3,vimc,uvcvideo,simple")
+ '())
"-Dudev=enabled"
"-Dtest=true" "-Dv4l2=true"
;; XXX: Requires bundled pybind11.