aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 16:05:24 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 16:07:21 -0400
commit1f7d94597f1e78776f854eeca46c03a3aded8466 (patch)
tree8228ad352ee7edcf7c4e3b0b8ffa8edc34543edb /gnu/packages
parentd0f0de4bf69da33037d2c9316edd7a58fa8afa96 (diff)
downloadguix-1f7d94597f1e78776f854eeca46c03a3aded8466.tar.gz
guix-1f7d94597f1e78776f854eeca46c03a3aded8466.zip
gnu: docbook-xsl: Replace with docbook-xsl-next.
* gnu/packages/docbook.scm (docbook-xsl): Replace with... (docbook-xsl-next): ... this package, adding the missing home-page, synopsis, description and license fields to the later, and removing the inheritance.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/docbook.scm74
-rw-r--r--gnu/packages/samba.scm2
2 files changed, 13 insertions, 63 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 30d360e81f..f66ce4b959 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -187,71 +187,16 @@ by no means limited to these applications.) This package provides XML DTDs.")
(string-append dtd "/docbookx.dtd") catalog.xml)))))
(native-inputs (list libxml2 unzip))))
+;;; There's an issue in docbook-xsl 1.79.2 that causes manpages to be
+;;; generated incorrectly and embed raw nroff syntax such as '.PP' when there
+;;; is a namespace/non-namespace mismatch between the sources and the
+;;; stylesheets used (see:
+;;; https://github.com/docbook/xslt10-stylesheets/issues/109).
(define-public docbook-xsl
- (package
- (name "docbook-xsl")
- (version "1.79.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/docbook/xslt10-stylesheets"
- "/releases/download/release%2F" version
- "/docbook-xsl-" version ".tar.bz2"))
- (patches (search-patches "docbook-xsl-support-old-url.patch"
- "docbook-xsl-nonrecursive-string-subst.patch"))
- (sha256
- (base32
- "0wd33z41kdsybyx3ay21w6bdlmgpd9kyn3mr5y520lsf8km28r9i"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- (for-each delete-file (find-files "." "\\.jar$"))
- #t))))
- (build-system trivial-build-system)
- (arguments
- `(#:builder (begin
- (use-modules (guix build utils))
-
- (define name-version
- (string-append ,name "-" ,version))
-
- (let* ((bzip2 (assoc-ref %build-inputs "bzip2"))
- (xz (assoc-ref %build-inputs "xz"))
- (tar (assoc-ref %build-inputs "tar"))
- (source (assoc-ref %build-inputs "source"))
- (out (assoc-ref %outputs "out"))
- (xsl (string-append out "/xml/xsl")))
- (setenv "PATH" (string-append bzip2 "/bin" ":" xz "/bin"))
- (invoke (string-append tar "/bin/tar") "xvf" source)
-
- (mkdir-p xsl)
- (copy-recursively name-version
- (string-append xsl "/" name-version))
-
- (substitute* (string-append xsl "/" name-version "/catalog.xml")
- (("rewritePrefix=\"./")
- (string-append "rewritePrefix=\"file://" xsl "/"
- name-version "/")))
- #t))
- #:modules ((guix build utils))))
- (native-inputs (list bzip2 xz ;needed for repacked tarballs
- tar))
- (home-page "https://docbook.org")
- (synopsis "DocBook XSL style sheets for document authoring")
- (description
- "This package provides XSL style sheets for DocBook.")
- (license (license:x11-style "" "See 'COPYING' file."))))
-
-;;; TODO: Make this the default docbook-xsl on core-updates. There's an issue
-;;; in docbook-xsl 1.79.2 that causes manpages to be generated incorrectly and
-;;; embed raw nroff syntax such as '.PP' when there is a
-;;; namespace/non-namespace mismatch between the sources and the stylesheets
-;;; used (see: https://github.com/docbook/xslt10-stylesheets/issues/109).
-(define-public docbook-xsl-next
(let ((commit "fe16c90013b64e316c3e21ef92d1e8813c10f88c")
(revision "0")
- (base-version (package-version docbook-xsl)))
+ (base-version "1.79.2"))
(package
- (inherit docbook-xsl)
(name "docbook-xsl")
(version (git-version base-version revision commit))
(source (origin
@@ -333,7 +278,12 @@ by no means limited to these applications.) This package provides XML DTDs.")
(native-inputs (list libxml2
libxslt
perl
- perl-xml-xpath)))))
+ perl-xml-xpath))
+ (home-page "https://docbook.org")
+ (synopsis "DocBook XSL style sheets for document authoring")
+ (description
+ "This package provides XSL style sheets for DocBook.")
+ (license (license:x11-style "" "See 'COPYING' file.")))))
(define-public docbook-xsl-1.79.1
(package
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index 590f7c4668..a680a26413 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -278,7 +278,7 @@ external dependencies.")
python-pyasn1 ;for krb5 tests
;; For generating man pages.
docbook-xml-4.2
- docbook-xsl-next ;otherwise the man pages are corrupted
+ docbook-xsl
libxslt
libxml2)) ;for XML_CATALOG_FILES
(home-page "https://www.samba.org/")