aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorIgor Goryachev via Guix-patches via <guix-patches@gnu.org>2024-08-05 13:44:47 +0300
committerAndrew Tropin <andrew@trop.in>2024-08-05 17:14:58 +0400
commit1f16e0f8d7f0f9dda835a2b4c88e2f4815707f90 (patch)
treea69493fd935a5986e485a9ed9a350254d081cd01 /gnu/packages
parent1bfc5418f2f69cdd3fd441ac9bf175963ec6f832 (diff)
downloadguix-1f16e0f8d7f0f9dda835a2b4c88e2f4815707f90.tar.gz
guix-1f16e0f8d7f0f9dda835a2b4c88e2f4815707f90.zip
gnu: Add erlang-p1-oauth2.
* gnu/packages/erlang-xyz.scm (erlang-p1-oauth2): New variable. Change-Id: I4d059e3c1fa644845787e70c3a4f7b0a3ebb4711 Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/erlang-xyz.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/erlang-xyz.scm b/gnu/packages/erlang-xyz.scm
index 81dfe1c5de..c50d7cc2da 100644
--- a/gnu/packages/erlang-xyz.scm
+++ b/gnu/packages/erlang-xyz.scm
@@ -89,6 +89,22 @@ Erlang and Elixir.")
(home-page "https://hex.pm/packages/jiffy")
(license license:expat)))
+(define-public erlang-p1-oauth2
+ (package
+ (name "erlang-p1-oauth2")
+ (version "0.6.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hexpm-uri "p1_oauth2" version))
+ (sha256
+ (base32 "13xfk4flaqb3nsxirf3vmy3yv67n6s6xzil7bafjswj39r3srlqz"))))
+ (build-system rebar-build-system)
+ (synopsis "OAuth 2.0 implementation for Erlang")
+ (description "This package provides OAuth 2.0 implementation for Erlang.")
+ (home-page "https://hex.pm/packages/p1_oauth2")
+ (license (list license:expat license:asl2.0))))
+
(define-public erlang-p1-utils
(package
(name "erlang-p1-utils")