aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 00:34:18 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:19 +0200
commit1d8451ddedb79f19acc9ac4035b1b47f5a2efeb1 (patch)
treefa59d219c07685d341244df5f4cd97a4242c3e12 /gnu/packages
parent75442a5e2d493f79c8c33e2b358b4fbc0532c3ec (diff)
downloadguix-1d8451ddedb79f19acc9ac4035b1b47f5a2efeb1.tar.gz
guix-1d8451ddedb79f19acc9ac4035b1b47f5a2efeb1.zip
gnu: Add texlive-hobby.
* gnu/packages/tex.scm (texlive-hobby): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 52487ac2e9..b986e6dd42 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -17535,6 +17535,26 @@ the option in an acceptable framework.")
both documents and presentations, us TikZ.")
(license license:lppl1.3+)))
+(define-public texlive-hobby
+ (package
+ (name "texlive-hobby")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/hobby/" "source/latex/hobby/"
+ "tex/latex/hobby/")
+ (base32
+ "1y0np4xpra136y2rqlwsifas33avfrv1psr8nxa92m7vmpd7l7fg")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/hobby")
+ (synopsis "Implementation of Hobby's algorithm for PGF/TikZ")
+ (description
+ "This package defines a path generation function for PGF/TikZ which
+implements Hobby's algorithm for a path built out of Bezier curves which
+passes through a given set of points.")
+ (license license:lppl1.3+)))
+
(define-public texlive-inlinedef
(package
(name "texlive-inlinedef")