aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-10 14:55:49 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:19:09 +0000
commit1b577b873462688a7ab3247f720dde25c7c5cb97 (patch)
tree01b3dab12dc4200167f1675483c8c28d60db8ba1 /gnu/packages
parent62f52b0e7138099c35b5f97e3ed548b9d237efc2 (diff)
downloadguix-1b577b873462688a7ab3247f720dde25c7c5cb97.tar.gz
guix-1b577b873462688a7ab3247f720dde25c7c5cb97.zip
gnu: python-pluggy: Update to 1.5.0.
* gnu/packages/python-build.scm (python-pluggy): Update to 1.5.0. Fix indentation. [build-system]: Swap to pyproject-build-system. [native-inputs]: Add python-setuptools and python-wheel. [home-page]: Place above synopsis. Change-Id: I960e37277b16f4f36f121097cd4b64765b49064f
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-build.scm35
1 files changed, 19 insertions, 16 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 80f75a188e..9077eb854a 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -71,22 +71,25 @@ matching of file paths.")
(define-public python-pluggy
(package
- (name "python-pluggy")
- (version "1.0.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pluggy" version))
- (sha256
- (base32
- "0n8iadlas2z1b4h0fc73b043c7iwfvx9rgvqm1azjmffmhxkf922"))))
- (build-system python-build-system)
- (native-inputs (list python-setuptools-scm))
- (synopsis "Plugin and hook calling mechanism for Python")
- (description "Pluggy is an extraction of the plugin manager as used by
-Pytest but stripped of Pytest specific details.")
- (home-page "https://pypi.org/project/pluggy/")
- (license license:expat)))
+ (name "python-pluggy")
+ (version "1.5.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pluggy" version))
+ (sha256
+ (base32 "1w8c3mpliqm9biqw75ci8cfj1x5pb6g5zwblqp27ijgxjj7aizrc"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (home-page "https://pypi.org/project/pluggy/")
+ (synopsis "Plugin and hook calling mechanism for Python")
+ (description
+ "Pluggy is an extraction of the plugin manager as used by Pytest but
+stripped of Pytest specific details.")
+ (license license:expat)))
(define-public python-pluggy-next
(package/inherit python-pluggy