aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:45 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:52 +0000
commit1a09cdc12e503043ea5cd4b1c8ef3c46534c635d (patch)
treef8225525fd802ffd65774a5d0071dfe5eb859134 /gnu/packages
parent15058ab04246c8ddc43466b5f0f652403bb10464 (diff)
downloadguix-1a09cdc12e503043ea5cd4b1c8ef3c46534c635d.tar.gz
guix-1a09cdc12e503043ea5cd4b1c8ef3c46534c635d.zip
gnu: python-pytest-toolbox: Move to pyproject-build-system.
* gnu/packages/python-check.scm (python-pytest-toolbox): [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Restrict 'check phase replacement to 'pre-check phase. Change-Id: Id0804db32d30314076d1e411711881bbe3a3f6e1 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/python-check.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 0be97411cb..aa915731fd 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1606,18 +1606,16 @@ service processes for your tests with pytest.")
(file-name (git-file-name name version))
(sha256
(base32 "1wqkr3g5gmqdxmhzfsxbwy8pm3cadaj6a8cxq58w9bacly4hqbh0"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (substitute* "setup.cfg"
- ((".*timeout.*") ""))
- ;; Make the installed plugin discoverable by Pytest.
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv")))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (substitute* "setup.cfg"
+ ((".*timeout.*") ""))))))))
(native-inputs
(list python-pydantic python-pytest python-pytest-isort))
(home-page "https://github.com/samuelcolvin/pytest-toolbox")