aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-08-19 21:37:55 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-08-19 21:37:55 +0200
commit19d3af452547a923b07869cc571fb41f681cf847 (patch)
treed5cd0ef1043f27b2f0f2345c727a41f7f7b2af9f /gnu/packages
parent3553b27f35a8038cf2f5c171756d81f0a2729897 (diff)
downloadguix-19d3af452547a923b07869cc571fb41f681cf847.tar.gz
guix-19d3af452547a923b07869cc571fb41f681cf847.zip
gnu: Add emacs-llama.
* gnu/packages/emacs-xyz.scm (emacs-llama): New variable. Change-Id: I2b3ccf0a9a706859ee50f6f6ad74f0cb8db7b129
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f5d18fa6e1..cf1e161d2a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1656,6 +1656,32 @@ on stdout instead of using a socket as the Emacsclient does.")
libgit2 bindings for Emacs, intended to boost the performance of Magit.")
(license license:gpl2+))))
+(define-public emacs-llama
+ (package
+ (name "emacs-llama")
+ (version "0.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tarsius/llama")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0rgm5jv9iv8b0xabdwicrpih2d3slchmv17xdjk705dqhfc18f4w"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:tests? #true
+ #:test-command #~(list "emacs" "-Q" "--batch"
+ "-l" "llama.el"
+ "-f" "ert-run-tests-batch-and-exit")))
+ (home-page "https://github.com/tarsius/llama")
+ (synopsis "Compact syntax for short lambda")
+ (description
+ "This package implements the macro @code{##}, which provides compact
+syntax for short lambda.")
+ (license license:gpl3+)))
+
(define-public emacs-llm
(package
(name "emacs-llm")