aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-02-18 12:07:09 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:54 +0200
commit19c153c15eff3ed7fdc19205693639201f96c66f (patch)
tree778bfad2669377df9309175abe6d15165bfc8c27 /gnu/packages
parentf0778b0d4d17101c02d105ff40df105743f6ab2a (diff)
downloadguix-19c153c15eff3ed7fdc19205693639201f96c66f.tar.gz
guix-19c153c15eff3ed7fdc19205693639201f96c66f.zip
gnu: talloc: Remove reference to crypt.
* gnu/packages/samba.scm (talloc): Remove reference to crypt header. Change-Id: I370069acdd7992f2660aae0b1840ea7756befe13
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/samba.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index ce707a8912..bf92b210c3 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -322,6 +322,14 @@ Desktops into Active Directory environments using the winbind daemon.")
(arguments
'(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'remove-crypt-reference
+ ;; The following is needed because Python.h propagates
+ ;; HAVE_CRYPT_H, which is then seen from lib/replace/ but talloc
+ ;; doesn't need it at all.
+ (lambda _
+ (substitute* "lib/replace/replace.h"
+ (("#include <crypt.h>")
+ ""))))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
;; talloc uses a custom configuration script that runs a Python