aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-05 02:00:46 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-13 02:04:33 -0400
commit184d61114f026477d7527aaa2441795cf6091973 (patch)
tree8dafb0817040097e2e43feca4000ceac13f76e1f /gnu/packages
parent3b366fd11899b2b9b7f11d60266b1ed23ad66ec5 (diff)
downloadguix-184d61114f026477d7527aaa2441795cf6091973.tar.gz
guix-184d61114f026477d7527aaa2441795cf6091973.zip
gnu: evince: Update to 42.3.
* gnu/packages/gnome.scm (evince): Update to 42.3. [meson]: Delete argument. [configure-flags]: Remove "-Dintrospection" and "-Dgtk_doc=false." [phases]: Delete trailing #t. [native-inputs]: Delete labels. Add gi-docgen. Replace intltool with gettext-minimal. Sort. [home-page]: Update URL.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/gnome.scm35
1 files changed, 14 insertions, 21 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5742651594..0e7a60a5cb 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2540,33 +2540,25 @@ forgotten when the session ends.")
(define-public evince
(package
(name "evince")
- (version "40.2")
+ (version "42.3")
(source (origin
(method url-fetch)
- (uri "mirror://gnome/sources/evince/40/evince-40.2.tar.xz")
+ (uri "mirror://gnome/sources/evince/42/evince-42.3.tar.xz")
(sha256
(base32
- "0xrwls1bhvny8vvd7mfjy9p26zjch0pd6x6j9jn9g2ka6xwyrxqg"))))
+ "0pk42icnf4kdcaqaj17mcf4sxi82h1fdg2ds2zdrcv4lbj2czbj9"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
- #:meson ,meson-0.60
#:build-type "release"
- #:configure-flags
- '("-Dnautilus=false"
- "-Dintrospection=true"
- ;; XXX: Generating the documentation fails because the
- ;; libevdocument.devhelp document cannot be created. This seems to be
- ;; caused by a problem during the XSL transformation.
- "-Dgtk_doc=false")
+ #:configure-flags '("-Dnautilus=false")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
(substitute* "meson_post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t)))))
+ (("gtk-update-icon-cache") "true")))))))
(inputs
(list libarchive
libgxps
@@ -2575,7 +2567,7 @@ forgotten when the session ends.")
ghostscript
poppler
libtiff
- texlive-libkpathsea ; for DVI support
+ texlive-libkpathsea ; for DVI support
gnome-desktop
gsettings-desktop-schemas
gspell
@@ -2595,13 +2587,14 @@ forgotten when the session ends.")
libsecret
libhandy))
(native-inputs
- `(("itstool" ,itstool)
- ("intltool" ,intltool)
- ("glib" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)
- ("xmllint" ,libxml2)))
- (home-page "https://www.gnome.org/projects/evince/")
+ (list itstool
+ gettext-minimal
+ gi-docgen
+ `(,glib "bin")
+ gobject-introspection
+ pkg-config
+ libxml2))
+ (home-page " https://wiki.gnome.org/Apps")
(synopsis "GNOME's document viewer")
(description
"Evince is a document viewer for multiple document formats. It