aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-08-28 20:59:40 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:12 +0200
commit17539a7ed1abba1f69045baf505581d0b5f2ccd2 (patch)
tree00538fa360a46d6320c7d10a84a60428e7d26262 /gnu/packages
parent3e6fe51f9a332315e9d90c3b0e6cd8299b7df3b8 (diff)
downloadguix-17539a7ed1abba1f69045baf505581d0b5f2ccd2.tar.gz
guix-17539a7ed1abba1f69045baf505581d0b5f2ccd2.zip
gnu: ghc-safe: Update to 0.3.17.
* gnu/packages/haskell.scm (ghc-safe): Update to 0.3.17. [native-inputs]: Add ghc-quickcheck.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/haskell.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f44eadbbe8..a4bb28eecd 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3144,7 +3144,7 @@ style.")
(define-public ghc-safe
(package
(name "ghc-safe")
- (version "0.3.9")
+ (version "0.3.17")
(source
(origin
(method url-fetch)
@@ -3154,8 +3154,10 @@ style.")
".tar.gz"))
(sha256
(base32
- "1jdnp5zhvalf1xy8i872n29nljfjz6lnl9ghj80ffisrnnkrwcfh"))))
+ "0p3yaf5slvyz1cyy51jq64c5rlp8yzwim8iy2dlnk42if4gc9ibr"))))
(build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)))
(home-page "https://github.com/ndmitchell/safe#readme")
(synopsis "Library of safe (exception free) functions")
(description "This library provides wrappers around @code{Prelude} and