aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
commit11f1d72dd8b0cac83cf73156abce909008cd7cdf (patch)
treeb4ccfe7c9d134ab8df1ff6360f099689b5970277 /gnu/packages
parentd7abe56433fea376d39c2cbec16df7e562714475 (diff)
downloadguix-11f1d72dd8b0cac83cf73156abce909008cd7cdf.tar.gz
guix-11f1d72dd8b0cac83cf73156abce909008cd7cdf.zip
gnu: xen: Update to 4.14.6.
* gnu/packages/virtualization.scm (xen): Update to 4.14.6. [arguments]: Remove obsolete quoting work-around for old bug. Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/virtualization.scm28
1 files changed, 10 insertions, 18 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index a1524d49be..7ab3354e64 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -2279,7 +2279,7 @@ DOS or Microsoft Windows.")
(define-public xen
(package
(name "xen")
- (version "4.14.1") ; please update the mini-os input as well
+ (version "4.14.6") ; please update the mini-os input as well
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2288,7 +2288,7 @@ DOS or Microsoft Windows.")
(file-name (git-file-name name version))
(sha256
(base32
- "1r90rvypw76ya9clqw5p02gm1k8hxz73f7gr95ca778nnzvb7xjw"))))
+ "1cdzpxbihkdn4za8ly0lgkbxrafjzbxjflhfn83kyg4bam1vv7mn"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
@@ -2340,8 +2340,7 @@ DOS or Microsoft Windows.")
(modify-phases %standard-phases
(add-after 'unpack 'unpack-mini-os
(lambda* (#:key inputs #:allow-other-keys)
- (copy-recursively (assoc-ref inputs "mini-os") "extras/mini-os")
- #t))
+ (copy-recursively (assoc-ref inputs "mini-os") "extras/mini-os")))
(add-after 'unpack-mini-os 'patch
(lambda* (#:key inputs outputs #:allow-other-keys)
(substitute* "tools/firmware/Rules.mk"
@@ -2374,13 +2373,7 @@ override CC = " (assoc-ref inputs "cross-gcc") "/bin/i686-linux-gnu-gcc"))
; TODO: extra_link_args = ['-Wl,-rpath=/opt/foo'],
(string-append "runtime_library_dirs = ['"
(assoc-ref outputs "out")
- "/lib'],\nlibrary_dirs =")))
-
- ;; This needs to be quoted:
- ;; <https://lists.gnu.org/archive/html/guix-devel/2022-03/msg00113.html>.
- (substitute* "xen/arch/x86/xen.lds.S"
- ((".note.gnu.build-id")
- "\".note.gnu.build-id\""))))
+ "/lib'],\nlibrary_dirs =")))))
(add-before 'configure 'patch-xen-script-directory
(lambda* (#:key outputs #:allow-other-keys)
(substitute* '("configure"
@@ -2389,8 +2382,7 @@ override CC = " (assoc-ref inputs "cross-gcc") "/bin/i686-linux-gnu-gcc"))
(("XEN_SCRIPT_DIR=.*")
(string-append "XEN_SCRIPT_DIR="
(assoc-ref outputs "out")
- "/etc/xen/scripts")))
- #t))
+ "/etc/xen/scripts")))))
(add-before 'configure 'set-environment-up
(lambda* (#:key make-flags #:allow-other-keys)
(define (cross? x)
@@ -2425,8 +2417,7 @@ override CC = " (assoc-ref inputs "cross-gcc") "/bin/i686-linux-gnu-gcc"))
"mini-os-git-checkout")))
'("C_INCLUDE_PATH" "CPLUS_INCLUDE_PATH"
"LIBRARY_PATH"))
- (setenv "EFI_VENDOR" "guix")
- #t))
+ (setenv "EFI_VENDOR" "guix")))
(replace 'build
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "make" "world" make-flags))))))
@@ -2463,10 +2454,11 @@ override CC = " (assoc-ref inputs "cross-gcc") "/bin/i686-linux-gnu-gcc"))
(url "https://xenbits.xen.org/git-http/mini-os.git")
;; This corresponds to (string-append "xen-RELEASE-" version))
;; at time of packaging, but upstream has unfortunately modified
- ;; existing tags in the past.
- (commit "0b4b7897e08b967a09bed2028a79fabff82342dd")))
+ ;; existing tags in the past. Also, not all Xen releases get a
+ ;; new tag. See <https://xenbits.xen.org/gitweb/?p=mini-os.git>.
+ (commit "f57858b7e8ef8dd48394dd08cec2bef3c9fb92f5")))
(sha256
- (base32 "1i8pcl19n60i2m9vlg79q3nknpj209c9ic5x10wxaicx45kc107f"))
+ (base32 "04y7grxs47amvjcq1rq4jgk174rhid5m2z9w8wrv7rfd2xhazxy1"))
(file-name (string-append name "-" version "-mini-os-git-checkout"))))
("perl" ,perl)
; TODO: markdown
) (dummy-fail-import, dummy-fail-console-script): New variables. ("python-build-system: dummy-ok") ("python-build-system: dummy-dummy-nosetuptools") ("python-build-system: dummy-fail-requirements") ("python-build-system: dummy-fail-import") ("python-build-system: dummy-fail-console-script"): Add tests. Lars-Dominik Braun 2021-02-01gnu: python: Replace PYTHONPATH by GUIX_PYTHONPATH....Using PYTHONPATH as a mean to discover the Python packages had the following issues: 1. It is not versioned, so different versions of Python would clash if installed in a shared profile. 2. It would interfere with the host Python site on foreign distributions, sometimes preventing a a user to login their GDM session (!). 3. It would take precedence over user installed Python packages installed through pip. 4. It would leak into Python virtualenvs, which are supposed to create isolated Python environments. This changes fixes the above issues by making use of a sitecustomize.py module. The newly introduced GUIX_PYTHONPATH environment variable is read from the environment, filtered for the current Python version of the interpreter, and spliced in 'sys.path' just before Python's own site location, which provides the expected behavior. * gnu/packages/aux-files/python/sitecustomize.py: New file. * Makefile.am: Register it. * gnu/packages/python.scm (customize-site) (guix-pythonpath-search-path): New procedures. (python-2.7)[phases]{install-sitecustomize.py}: New phase. [native-inputs]{sitecustomize.py}: New input. [native-search-paths]: Replace PYTHONPATH with GUIX_PYTHONPATH. (python-3.9)[native-search-paths]: Likewise. [phases]{install-sitecustomize}: Override with correct version. [native-search-paths]: Replace PYTHONPATH with GUIX_PYTHONPATH. * gnu/packages/commencement.scm (python-boot0): [phases]{install-sitecustomize}: Likewise. [native-inputs]{sitecustomize.py}: New input. [native-search-paths]: Replace PYTHONPATH with GUIX_PYTHONPATH. * guix/build/python-build-system.scm (site-packages): Do not add a trailing '/'. squash! gnu: python: Replace PYTHONPATH by GUIX_PYTHONPATH. Maxim Cournoyer 2021-01-28Makefile.am: Add check-po rule....* Makefile.am (make-check-po-rule): New definition. Add top-level 'eval' and calls to 'make-check-po-rule' to generate 'check-po.DOMAIN' rules. (check-po): New rule. Julien Lepiller 2021-01-28Makefile.am: Normalize downloaded po files....* Makefile.am (make-download-po-rule): Normalize po files. Julien Lepiller 2021-01-20Makefile.am: Download po files from weblate....* Makefile.am (download-po): Download from weblate. Julien Lepiller 2021-01-16guix: Move narinfo code from substitute script to module....This separation between the code for dealing with narinfos from the code doing that for a purpose should make things clearer, and better support components other that the substitute script in using this code. This is just moving the code around, no code should have been significantly changed. * guix/scripts/substitute.scm (<narinfo>): Move record type to (guix narinfo). (fields->alist, narinfo-hash-algorithm+value, narinfo-hash->sha256, narinfo-signature->canonical-sexp, narinfo-maker, read-narinfo, narinfo-sha256, valid-narinfo?, write-narinfo, narinfo->string, string->narinfo, equivalent-narinfo?, supported-compression?, compresses-better?, narinfo-best-uri): Move procedures to (guix narinfo). (%compression-methods): Move variable to (guix narinfo). * guix/narinfo.scm: New file. * Makefile.am (MODULES): Add it. * po/guix/POTFILES.in: Add 'guix/narinfo.scm'. Christopher Baines 2021-01-13Merge branch 'staging' into 'core-updates'....Conflicts: gnu/local.mk gnu/packages/cmake.scm gnu/packages/curl.scm gnu/packages/gl.scm gnu/packages/glib.scm gnu/packages/guile.scm gnu/packages/node.scm gnu/packages/openldap.scm gnu/packages/package-management.scm gnu/packages/python-xyz.scm gnu/packages/python.scm gnu/packages/tls.scm gnu/packages/vpn.scm gnu/packages/xorg.scm Maxim Cournoyer 2021-01-09tests: Run 'tests/offload.scm' only when BUILD_DAEMON_OFFLOAD is true....Fixes: guix build -e '(@ (gnu packages package-management) guix-minimal)' * Makefile.am (SCM_TESTS): Move 'tests/offload.scm' within "if BUILD_DAEMON_OFFLOAD" conditional. Ludovic Courtès 2021-01-04graph: Install JavaScript files....Until now, 'guix graph --backend=d3js' wouldn't work outside the build tree. * d3.v3.js: Move to... * guix/d3.v3.js: ... here. * graph.js: Move to... * guix/graph.js: ... here. * Makefile.am (nobase_dist_guilemodule_DATA): Add them. (EXTRA_DIST): Remove them. * guix/graph.scm (emit-d3js-prologue, emit-d3js-epilogue): Adjust 'search-path' argument accordingly. * guix/self.scm (compiled-guix)[*extra-modules*]: Pass them via #:extra-files. Ludovic Courtès 2020-12-27maint: Remove unused '--with-nix-prefix' configure option....* configure.ac: Remove '--with-nix-prefix' and 'NIX_PREFIX' variable. * Makefile.am (AM_DISTCHECK_CONFIGURE_FLAGS): Remove '--with-nix-prefix'. Ludovic Courtès 2020-12-20gnu: vim: Automatically find vim plugins....* gnu/packages/vim.scm (vim)[arguments]: Add new 'install-guix.vim phase to install vendor specific vimrc. * gnu/packages/aux-files/guix.vim: New file. * Makefile.am (AUX_FILES): Register it. Efraim Flashner 2020-12-19gnu: linux-libre: Update to 5.10.1....* gnu/packages/aux-files/linux-libre/5.10-arm.conf, gnu/packages/aux-files/linux-libre/5.10-arm64.conf, gnu/packages/aux-files/linux-libre/5.10-i686.conf, gnu/packages/aux-files/linux-libre/5.10-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them. * gnu/packages/linux.scm (linux-libre-5.10-version, deblob-scripts-5.10, linux-libre-5.10-pristine-source, linux-libre-5.10-source, linux-libre-headers-5.10, linux-libre-5.10): New variables. (linux-libre-version, linux-libre-pristine-source, linux-libre-source, linux-libre, linux-libre-with-bpf): Update to 5.10.1. Leo Famulari 2020-12-11build: 'script/guix' uses our own 'guile' executable....* Makefile.am (do_subst): Substitute @abs_top_builddir@. * scripts/guix.in: Use it. Ludovic Courtès 2020-12-03build-system: Add chicken-build-system....* guix/build-system/chicken.scm: New file. * guix/build/chicken-build-system.scm: New file. * Makefile.am: Add them. * doc/guix.texi: Document it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> raingloom