aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 10:33:47 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-03-06 12:22:13 +0100
commit11302036f7b990bdf41ce5128ccbad3edad76b84 (patch)
tree61423cbee56bd10c7697186cb8f38a8272b26d3d /gnu/packages
parentb2907f5b25d7fc177bf54701de4e3067ff94f9c5 (diff)
downloadguix-11302036f7b990bdf41ce5128ccbad3edad76b84.tar.gz
guix-11302036f7b990bdf41ce5128ccbad3edad76b84.zip
gnu: texlive-generic-kvdefinekeys: Rename to texlive-kvdefinekeys.
* gnu/packages/tex.scm (texlive-kvdefinekeys): New variable. (texlive-generic-kvdefinekeys): Deprecated alias. (texlive-hyperref): * gnu/packages/plotutils.scm (asymptote): Use new name.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/plotutils.scm2
-rw-r--r--gnu/packages/tex.scm53
2 files changed, 40 insertions, 15 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 78fbc3c9b4..26623bc487 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -296,7 +296,7 @@ colors, styles, options and details.")
texlive-etoolbox
texlive-fonts-ec
texlive-infwarerr
- texlive-generic-kvdefinekeys
+ texlive-kvdefinekeys
texlive-grfext
texlive-hyperref
texlive-latex-base
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 861ffcc4f7..69d7cc82ab 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3463,7 +3463,7 @@ XML, using UTF-8 or a suitable 8-bit encoding.")
texlive-iftex
texlive-infwarerr
texlive-intcalc
- texlive-generic-kvdefinekeys
+ texlive-kvdefinekeys
texlive-generic-kvsetkeys
texlive-generic-ltxcmds
texlive-generic-pdfescape
@@ -8333,20 +8333,45 @@ using the e-TeX extension @code{\\numexpr} if it is available.")
(define-deprecated-package texlive-generic-intcalc texlive-intcalc)
-(define-public texlive-generic-kvdefinekeys
- (package
- (inherit (simple-texlive-package
- "texlive-generic-kvdefinekeys"
- '("/tex/generic/kvdefinekeys/")
- (base32
- "12nn74skhwiszbdhawqds31caz6d59a5pjmwar0r8lmk4f1jr3xh")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/kvdefinekeys")
- (synopsis "Define keys for use in the @code{kvsetkeys} package")
- (description
- "This package provides the @code{\\kv@@define@@key} (analogous to
+(define-public texlive-kvdefinekeys
+ (let ((template (simple-texlive-package
+ "texlive-kvdefinekeys"
+ (list "doc/latex/kvdefinekeys/"
+ "source/latex/kvdefinekeys/"
+ "tex/generic/kvdefinekeys/")
+ (base32
+ "1026h223ph3nzhs6jqbasa0bzsrdg3zgllfcwwcavfzb5i6p9jdf"))))
+ (package
+ (inherit template)
+ (outputs '("out" "doc"))
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:tex-directory _ '())
+ "generic/kvdefinekeys")
+ ((#:build-targets _ '())
+ #~(list "kvdefinekeys.dtx"))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "source/latex/kvdefinekeys")))
+ (replace 'copy-files
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((origin (assoc-ref inputs "source"))
+ (source (string-append #$output
+ "/share/texmf-dist/source"))
+ (doc (string-append #$output:doc
+ "/share/texmf-dist/doc")))
+ (copy-recursively (string-append origin "/source") source)
+ (copy-recursively (string-append origin "/doc") doc))))))))
+ (home-page "https://www.ctan.org/pkg/kvdefinekeys")
+ (synopsis "Define keys for use in the @code{kvsetkeys} package")
+ (description
+ "This package provides the @code{\\kv@@define@@key} (analogous to
keyval’s @code{\\define@@key}, to define keys for use by @code{kvsetkeys}.")
- (license license:lppl1.3c+)))
+ (license license:lppl1.3c+))))
+
+(define-deprecated-package texlive-generic-kvdefinekeys texlive-kvdefinekeys)
(define-public texlive-generic-kvsetkeys
(package