aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 12:41:23 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:53:56 +0200
commit0fe4601516c878dfd3b40f796f85a4038f086637 (patch)
tree90914762de68892ebf267964c1278e3969e0fce6 /gnu/packages
parent3e4e74c10ec1bf57ffcaed987b75127382908697 (diff)
downloadguix-0fe4601516c878dfd3b40f796f85a4038f086637.tar.gz
guix-0fe4601516c878dfd3b40f796f85a4038f086637.zip
gnu: emacs-js2-mode: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-js2-mode)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c9cbbaa154..3a21c81f59 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4637,14 +4637,15 @@ to all the other commands, too.")
(package
(name "emacs-js2-mode")
(version "20190219")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mooz/js2-mode/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1gv1vinp2avnnn6an8ffcx79vmsdjhhikz7s6cmphligb26qp2vi"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mooz/js2-mode.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0766bbr4piia9vfr4ivd2gwi8dxah654adv6h28ylz4q8xmfzm1b"))))
(build-system emacs-build-system)
(home-page "https://github.com/mooz/js2-mode/")
(synopsis "Improved JavaScript editing mode for Emacs")