aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorYovan Naumovski <yovan@gorski.stream>2023-04-07 20:45:23 +0300
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-09 21:00:05 +0200
commit0cbbfc05bf2b22ee0f0fda23939a5e6b374022b5 (patch)
tree2a045d2235c707711611a6d3bca5e915db1d730b /gnu/packages
parent514df2930c502f192767493e5caaef82e5fd8748 (diff)
downloadguix-0cbbfc05bf2b22ee0f0fda23939a5e6b374022b5.tar.gz
guix-0cbbfc05bf2b22ee0f0fda23939a5e6b374022b5.zip
gnu: haproxy: Update to 2.7.6.
* gnu/packages/high-availability.scm (haproxy): Update to 2.7.6. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/high-availability.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/high-availability.scm b/gnu/packages/high-availability.scm
index ad6db537e5..35bb28786b 100644
--- a/gnu/packages/high-availability.scm
+++ b/gnu/packages/high-availability.scm
@@ -60,7 +60,7 @@
(define-public haproxy
(package
(name "haproxy")
- (version "2.7.5")
+ (version "2.7.6")
(source
(origin
(method url-fetch)
@@ -68,7 +68,7 @@
(version-major+minor version)
"/src/haproxy-" version ".tar.gz"))
(sha256
- (base32 "00j5lwvrf8lgfid3108gclxbd46v3mnd4lh0lw4l0nn3f0rf9ip2"))))
+ (base32 "0kxpvrn6iaxhw2f2hrxblns6pnxmrds3vvs9h6nwbkrzvdykagqk"))))
(build-system gnu-build-system)
(arguments
(list
v>
- ;; XXX: consume all LFs even if not followed by CR.
- ((eqv? byte (char->integer #\return)) (loop count (get-u8 port)))
(else
(bytevector-u8-set! bv (+ start count) byte)
(loop (+ count 1) (get-u8 port))))))
diff --git a/tests/utils.scm b/tests/utils.scm
index 44861384ab..f78ec356bd 100644
--- a/tests/utils.scm
+++ b/tests/utils.scm
@@ -230,6 +230,12 @@ skip these tests."
"This is a journey\r\nInto the sound\r\nA journey ...\n")))
(get-string-all (canonical-newline-port port))))
+(test-equal "canonical-newline-port-1024"
+ (string-concatenate (make-list 100 "0123456789abcde\n"))
+ (let ((port (open-string-input-port
+ (string-concatenate
+ (make-list 100 "0123456789abcde\r\n")))))
+ (get-string-all (canonical-newline-port port))))
(test-equal "edit-expression"
"(display \"GNU Guix\")\n(newline)\n"