aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2024-08-27 17:36:42 +0200
committerLudovic Courtès <ludo@gnu.org>2024-09-05 10:14:24 +0200
commit0b6586a2237ed45bc07578ecc0d6e74cbd62f8cb (patch)
treeaa724b986e09feb0aaf139d31a561c23c4bfbdbf /gnu/packages
parentb4a8f5d7841ae91261d8f94be50a199bd36d056c (diff)
downloadguix-0b6586a2237ed45bc07578ecc0d6e74cbd62f8cb.tar.gz
guix-0b6586a2237ed45bc07578ecc0d6e74cbd62f8cb.zip
gnu: python-slepc4py: Update to 3.21.1.
* gnu/packages/maths.scm (python-slepc4py): Update to 3.21.1. [arguments]: Switch to gexps. Replace ‘check’ phase. [native-inputs]: New field. [inputs]: Remove labels. Add ‘petsc-openmpi’. Change-Id: Ib6f1480415ac5128399c32c1974779b67edb5550
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/maths.scm35
1 files changed, 18 insertions, 17 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 533077b485..39c9c18922 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4053,31 +4053,32 @@ arising after the discretization of partial differential equations.")
(define-public python-slepc4py
(package
(name "python-slepc4py")
- (version "3.16.1")
+ (version "3.21.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "slepc4py" version))
(sha256
(base32
- "0fq997y73ymvcvdrxycp450pxwdgnqaw62gv9rwncfgsfplkvs9w"))))
+ "01vvpl8g73knkwnh6mbxd45vwcs4zsw814147fvgkvj30qkhx3mw"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'pre-build
- (lambda _
- ;; Define path to PETSc installation.
- (setenv "PETSC_DIR" (assoc-ref %build-inputs "petsc"))
- ;; Define path to SLEPc installation.
- (setenv "SLEPC_DIR" (assoc-ref %build-inputs "slepc"))
- #t))
- (add-before 'check 'mpi-setup
- ,%openmpi-setup))))
- (inputs
- `(("python-numpy" ,python-numpy)
- ("python-petsc4py" ,python-petsc4py)
- ("slepc" ,slepc-openmpi)))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'pre-build
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Define path to PETSc installation.
+ (setenv "PETSC_DIR" (assoc-ref inputs "petsc-openmpi"))
+ ;; Define path to SLEPc installation.
+ (setenv "SLEPC_DIR" (assoc-ref inputs "slepc-openmpi"))))
+ (add-before 'check 'mpi-setup
+ #$%openmpi-setup)
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "test/runtests.py")))))))
+ (native-inputs (list python-cython-3))
+ (inputs (list python-numpy python-petsc4py petsc-openmpi slepc-openmpi))
(home-page "https://bitbucket.org/slepc/slepc4py/")
(synopsis "Python bindings for SLEPc")
(description "SLEPc, the Scalable Library for Eigenvalue Problem