aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-09 00:12:06 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:20 +0300
commit0a99022229996492eecaba16968dad750c05fa65 (patch)
treef9cf9486a40cb3ac999ab65f8903cb074b05cfce /gnu/packages
parentfa70d264dd1238f72b81eadbbfef41d59c347e04 (diff)
downloadguix-0a99022229996492eecaba16968dad750c05fa65.tar.gz
guix-0a99022229996492eecaba16968dad750c05fa65.zip
gnu: Add go-github-com-aymerick-douceur.
* gnu/packages/golang.scm (go-github-com-aymerick-douceur): New variable.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cafd432cf7..0da0bd30ae 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4734,3 +4734,29 @@ the parse trees produced by the html package.")
(description "@code{goquery} brings a syntax and a set of features similar
to jQuery to the Go language.")
(license license:bsd-3)))
+
+(define-public go-github-com-aymerick-douceur
+ (package
+ (name "go-github-com-aymerick-douceur")
+ (version "0.2.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/aymerick/douceur/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hfysznib0fqbp8vqxpk0xiggpp0ayk2bsddi36vbg6f8zq5f81n"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/aymerick/douceur"))
+ (native-inputs
+ `(("go-github-com-puerkitobio-goquery" ,go-github-com-puerkitobio-goquery)
+ ("go-github-com-andybalholm-cascadia" ,go-github-com-andybalholm-cascadia)
+ ("go-golang-org-x-net" ,go-golang-org-x-net)
+ ("go-github-com-gorilla-css" ,go-github-com-gorilla-css)))
+ (home-page "https://github.com/aymerick/douceur/")
+ (synopsis "CSS parser and inliner")
+ (description "This package provides a CSS parser and inliner.")
+ (license license:expat)))
> 2019-05-25linux-container: Check if nscd run directory exists when container is run.Arun Isaac * gnu/system/linux-container.scm (containerized-operating-system): (container-script): Check for existence of the host nscd run directory in the container script. This check should be run when the container is started, not when the container script is created. [network-mappings]: Delete variable. [nscd-run-directory, nscd-mapping]: New variables. 2019-05-15linux-container: Compute essential services for THIS-OPERATING-SYSTEM.Ludovic Courtès Previously, the 'essential-services' would correspond to the initial, non-containerized OS. Thus, all the file systems removed in 'container-essential-services' would actually still be there because the essential services would be computed on the non-containerized OS. This is a followup to 69cae3d3356a69b7fe69481338f760545995485e. * gnu/system/linux-container.scm (container-essential-services): Call 'operating-system-default-essential-services' to get the baseline services. (containerized-operating-system): Pass THIS-OPERATING-SYSTEM, not OS, to 'container-essential-services'. Add a dummy root file system to 'file-systems'. (container-script)[mountable-file-system?]: New procedure. Use it. 2019-05-15linux-container: Do not add %CONTAINER-FILE-SYSTEMS to Docker image OSes.Ludovic Courtès Previously, 'guix system docker-image' would end up providing an OS that would try to mount all of %CONTAINER-FILE-SYSTEMS as well as /gnu/store, which is bound to fail in unprivileged Docker. This patch makes it so that 'guix system container' still gets those file systems, but 'guix system docker-image' doesn't. * gnu/system/linux-container.scm (containerized-operating-system): Add #:extra-file-systems parameter and honor it. Do not include %STORE-MAPPING and SHARED-NETWORK-FILE-MAPPINGS. (container-script): Add %STORE-MAPPING and optionally NETWORK-MAPPINGS to MAPPINGS and pass #:extra-file-systems. 2019-05-14linux-container: Support container network sharing.Arun Isaac * gnu/system/linux-container.scm (container-essential-services): If network is to be shared with the host, remove network configuration files from etc service. (containerized-operating-system): If network is to be shared with the host, remove nscd service and map host's /var/run/nscd if it exists. (container-script): If network is to be shared with the host, do not create network namespace. * guix/scripts/system.scm (system-derivation-for-action): Add #:container-shared-network? argument. (perform-action): Add #:container-shared-network? argument. (show-help): Add "-N, --network" help information. (%options): Add network option. (process-action): Call perform-action with #container-shared-network? argument. * doc/guix.texi (Invoking guix system): Document the "-N, --network" option. Co-authored-by: Christopher Baines <mail@cbaines.net> 2019-05-10linux-container: Improve filtering of unnecessary file systems.Ludovic Courtès * gnu/system/linux-container.scm (containerized-operating-system)[user-file-systems]: Add trailing slash for the "/dev/" and "/sys/" prefixes. 2019-04-23linux-container: Remove '%containerized-shepherd-service' hack.Ludovic Courtès This hack worked around a defect in the Shepherd 0.5.0 and is no longer needed. * gnu/services/shepherd.scm (%containerized-shepherd-service): Remove. * gnu/system/linux-container.scm (container-essential-services): Don't use it. 2019-03-25system: Add 'essential-services' field to <operating-system>.Ludovic Courtès * gnu/system.scm (<operating-system>)[essential-services]: New field. (operating-system-directory-base-entries): Remove #:container? keyword and keep only the not-container branch. (essential-services): Likewise. (operating-system-services): Likewise, and call 'operating-system-essential-services' instead of 'essential-services'. (operating-system-activation-script): Remove #:container?. (operating-system-boot-script): Likewise. (operating-system-derivation): Likewise. * gnu/system/linux-container.scm (container-essential-services): New procedure. (containerized-operating-system): Use it and set the 'essential-services' field. (container-script): Remove call to 'operating-system-derivation'. * gnu/system/vm.scm (system-docker-image): Likewise. * doc/guix.texi (operating-system Reference): Document 'essential-services'.