aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-26 23:50:21 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-27 00:33:34 +0100
commit099fb61112aeeb70c157640f98118baca1bcd1f0 (patch)
tree3f76456f1c0f66b8039f9eddda2039114168559e /gnu/packages
parent61656d3f617ef46673f5ee885ae998cfeb2c3b2f (diff)
downloadguix-099fb61112aeeb70c157640f98118baca1bcd1f0.tar.gz
guix-099fb61112aeeb70c157640f98118baca1bcd1f0.zip
gnu: go-go-etcd-io-bbolt: Update to 1.3.11.
* gnu/packages/golang-xyz.scm (go-go-etcd-io-bbolt): Update to 1.3.11. [native-inputs]: Add go-github-com-stretchr-testify, go-go-etcd-io-gofail, and go-golang-org-x-sync. Change-Id: I8bad82ce8006360cfa3cc509ccdff02e06f703d3
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/golang-xyz.scm29
1 files changed, 17 insertions, 12 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index b2079e1aa1..be52c54e95 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6397,21 +6397,26 @@ Go host programs.")
(define-public go-go-etcd-io-bbolt
(package
(name "go-go-etcd-io-bbolt")
- (version "1.3.6")
+ (version "1.3.11")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/etcd-io/bbolt")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0pj5245d417za41j6p09fmkbv05797vykr1bi9a6rnwddh1dbs8d"))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/etcd-io/bbolt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "16s2l1yjn55rgybc9k8kh88zg7z8igm10y1xmx2qx1a147k64d31"))))
(build-system go-build-system)
(arguments
- `(#:import-path "go.etcd.io/bbolt"
- ;; Extending the test timeout to 30 minutes still times out on aarch64.
- #:tests? ,(not target-arm?)))
+ (list
+ ;; Extending the test timeout to 30 minutes still times out on aarch64.
+ #:tests? (not target-arm?)
+ #:import-path "go.etcd.io/bbolt"))
+ (native-inputs
+ (list go-github-com-stretchr-testify
+ go-go-etcd-io-gofail
+ go-golang-org-x-sync))
(propagated-inputs
(list go-golang-org-x-sys))
(home-page "https://go.etcd.io/bbolt")