aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-06 12:44:28 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:07 +0800
commit0588329a4a7312a7b5e26409fbb64f43ef41e15e (patch)
tree712ea742cfc0d698ee258f81a1298ed48c8a109f /gnu/packages
parent3d9eb8a27a7b458d5805ffc787ba90f2cdf7d3a4 (diff)
downloadguix-0588329a4a7312a7b5e26409fbb64f43ef41e15e.tar.gz
guix-0588329a4a7312a7b5e26409fbb64f43ef41e15e.zip
gnu: libkscreen: Update to 6.1.2.
* gnu/packages/kde-plasma.scm (libkscreen): Update to 6.1.2. [inputs]: Remove kconfig, qtbase-5, qtwayland-5, and qtx11extras; add qtwayland and libxkbcommon. [native-inputs]: Remove qttools-5; add qttools. [arguments]: Set #:qtbase to qtbase. <#:phases>: Adjust test. Change-Id: I32afffbe27ad18863e6963a26bcb90303a158721
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/kde-plasma.scm43
1 files changed, 24 insertions, 19 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 98d4f45ad2..8df3354c7c 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1033,39 +1033,44 @@ installed.")
(define-public libkscreen
(package
(name "libkscreen")
- (version "5.27.7")
+ (version "6.1.2")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/plasma/" version "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1ary7qavz8vkzbvjx2mxv09h61hxa7i4f7rfgbykldbc83ripdc6"))))
+ (base32 "1f4pb09b9n6fbwlcs5fva3wpfamg9maz2k4rf0dyr2ihyjwh3p1n"))))
(build-system qt-build-system)
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (setenv "HOME" (getcwd))
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (setenv "WAYLAND_DISPLAY" "libkscreen-test-wayland-backend-0")
- (invoke "ctest" "-E"
- (string-append "(kscreen-testedid"
- "|kscreen-testqscreenbackend"
- "|kscreen-testkwaylandbackend"
- "|kscreen-testkwaylandconfig"
- "|kscreen-testkwaylanddpms)"))))))))
+ (list
+ #:qtbase qtbase
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'check-env-setup
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "HOME" (getcwd))
+ (with-output-to-file "autotests/BLACKLIST"
+ (lambda _
+ (for-each
+ (lambda (name)
+ (display (string-append "[" name "]\n*\n")))
+ (list
+ "verifyOutputs"
+ ;; also fail on upstream
+ "testEdidParser"
+ "testEnv"))))))))))
(native-inputs
(list extra-cmake-modules
pkg-config
- qttools-5
+ qttools
;; For testing.
dbus))
(inputs
- (list kconfig kwayland libxrandr plasma-wayland-protocols
- qtbase-5 qtwayland-5 wayland qtx11extras))
+ (list kwayland libxrandr plasma-wayland-protocols qtwayland
+ wayland
+ libxkbcommon))
(home-page "https://community.kde.org/Solid/Projects/ScreenManagement")
(synopsis "KDE's screen management software")
(description "KScreen is the new screen management software for KDE Plasma