aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-12-20 19:00:15 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:16 +0200
commit052d12f040c9f253032ee4af0145aa5a7b90872c (patch)
tree44ec225d1938f02ba5adb8f662fb7b9cc3335e71 /gnu/packages
parent45d66ce8e995761dcde73c7ae437e00ab91ab8d7 (diff)
downloadguix-052d12f040c9f253032ee4af0145aa5a7b90872c.tar.gz
guix-052d12f040c9f253032ee4af0145aa5a7b90872c.zip
gnu: guile-gnutls: Update to 4.0.0.
* gnu/packages/tls.scm (guile-gnutls): Update to 4.0.0. [source]: Remove “gnutls-cross.patch”. [arguments]: Add #:make-flags. * gnu/packages/patches/gnutls-cross.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Change-Id: Ic4432e2d5ca37af5aa20cdf7e4e456afe2b37537
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/patches/gnutls-cross.patch82
-rw-r--r--gnu/packages/tls.scm6
2 files changed, 5 insertions, 83 deletions
diff --git a/gnu/packages/patches/gnutls-cross.patch b/gnu/packages/patches/gnutls-cross.patch
deleted file mode 100644
index 82d08da24e..0000000000
--- a/gnu/packages/patches/gnutls-cross.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-Not sent upstream.
-
-From e23de62e28f64599148ff06e439fac116a391299 Mon Sep 17 00:00:00 2001
-From: "Jan (janneke) Nieuwenhuizen" <janneke@gnu.org>
-Date: Fri, 10 Apr 2020 07:24:48 +0200
-Subject: [PATCH] guile: Cross build fix.
-
-To cross-build, both the host guile and the native guile-for-build
-must be available. If the native guile is not available, no snarfing
-is done and the guile cross build is skipped.
-
-During the cross-build gnutls.scm does not load when compliling
-extra.scm, becase of missing definitions from guile-gnutls-v-2.
-
-* guile/modules/gnutls.in (protocol/ssl-3 protocol/tls-1.0,
-protocol/tls-1.1, credentials/anonymous, cipher/rijndael-256-cbc,
-cipher/rijndael-128-cbc, cipher/rijndael-cbc, cipher/arcfour-128,
-certificate-verify/allow-any-x509-v1-ca-certificate,
-certificate-verify/allow-x509-v1-ca-certificate): Define to #f
-initially. When "GNUTLS_GUILE_CROSS_COMPILING" not set, set! to value
-from "guile-gnutls-v-2" load-extension C module.
----
- guile/modules/gnutls.in | 40 +++++++++++++++++++++++++++-------------
- 1 file changed, 27 insertions(+), 13 deletions(-)
-
-diff --git a/guile/modules/gnutls.in b/guile/modules/gnutls.in
-index 6461c404a..954e315de 100644
---- a/guile/modules/gnutls.in
-+++ b/guile/modules/gnutls.in
-@@ -564,22 +564,36 @@ This defines 'variable' as an alias for 'alias', and emits a warning when
- (identifier? #'id)
- #'alias))))))))))
-
--
- ;; Renaming.
--(define protocol/ssl-3 protocol/ssl3)
--(define protocol/tls-1.0 protocol/tls1-0)
--(define protocol/tls-1.1 protocol/tls1-1)
-+(define protocol/ssl-3 #f)
-+(define protocol/tls-1.0 #f)
-+(define protocol/tls-1.1 #f)
-
- ;; Aliases.
--(define credentials/anonymous credentials/anon)
--(define cipher/rijndael-256-cbc cipher/aes-256-cbc)
--(define cipher/rijndael-128-cbc cipher/aes-128-cbc)
--(define cipher/rijndael-cbc cipher/aes-128-cbc)
--(define cipher/arcfour-128 cipher/arcfour)
--(define certificate-verify/allow-any-x509-v1-ca-certificate
-- certificate-verify/allow-any-x509-v1-ca-crt)
--(define certificate-verify/allow-x509-v1-ca-certificate
-- certificate-verify/allow-x509-v1-ca-crt)
-+(define credentials/anonymous #f)
-+(define cipher/rijndael-256-cbc #f)
-+(define cipher/rijndael-128-cbc #f)
-+(define cipher/rijndael-cbc #f)
-+(define cipher/arcfour-128 #f)
-+(define certificate-verify/allow-any-x509-v1-ca-certificate #f)
-+(define certificate-verify/allow-x509-v1-ca-certificate #f)
-+
-+(unless (getenv "GNUTLS_GUILE_CROSS_COMPILING")
-+ ;; Renaming.
-+ (set! protocol/ssl-3 protocol/ssl3)
-+ (set! protocol/tls-1.0 protocol/tls1-0)
-+ (set! protocol/tls-1.1 protocol/tls1-1)
-+
-+ ;; Aliases.
-+ (set! credentials/anonymous credentials/anon)
-+ (set! cipher/rijndael-256-cbc cipher/aes-256-cbc)
-+ (set! cipher/rijndael-128-cbc cipher/aes-128-cbc)
-+ (set! cipher/rijndael-cbc cipher/aes-128-cbc)
-+ (set! cipher/arcfour-128 cipher/arcfour)
-+ (set! certificate-verify/allow-any-x509-v1-ca-certificate
-+ certificate-verify/allow-any-x509-v1-ca-crt)
-+ (set! certificate-verify/allow-x509-v1-ca-certificate
-+ certificate-verify/allow-x509-v1-ca-crt))
-
- ;; Deprecated OpenPGP bindings.
- (define-deprecated certificate-type/openpgp)
---
-2.26.0
-
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index ac03ff72ab..3fbcfeda0f 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -344,7 +344,11 @@ required structures.")
(string-append "--with-guile-site-ccache-dir="
"$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache")
(string-append "--with-guile-extension-dir="
- "$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions"))))
+ "$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/extensions"))
+
+ ;; The 'gnutls' package currently lacks support for SRP, making this
+ ;; test fail.
+ #:make-flags #~'("XFAIL_TESTS=tests/srp-base64.scm")))
(native-inputs
(list libtool
pkg-config