aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-11-01 16:31:03 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2018-02-18 18:39:19 +0100
commit042f7c2636a3595e2af970025854edcfd8860329 (patch)
tree18fe9d3337107ca523d9f0fb8878072d5c7682c3 /gnu/packages
parent64f390a40994da24d310c4894301585b4722912b (diff)
downloadguix-042f7c2636a3595e2af970025854edcfd8860329.tar.gz
guix-042f7c2636a3595e2af970025854edcfd8860329.zip
gnu: qtserialport: Use the store paths for dynamically loaded libs.
Transfer the applicable NixOS patches for qtserialport as of 2018-01-19: - src/serialport/qtudev_p.h: Transferred: Use hard-coded path to libudev. * gnu/packages/qt.scm(qtserialport)[#:phases]<patch-dlopen-paths>: New phase.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/qt.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 361bcf6b6e..4cf1ed5735 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -999,6 +999,19 @@ compositor libraries.")))
(inputs
`(("qtbase" ,qtbase)
("eudev" ,eudev)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments qtsvg)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'unpack 'patch-dlopen-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/serialport/qtudev_p.h"
+ ;; Use the absolute paths for dynamically loaded libs,
+ ;; otherwise the lib will be searched in LD_LIBRARY_PATH which
+ ;; typically is not set in guix.
+ (("^\\s*(udevLibrary->setFileNameAndVersion\\(QStringLiteral\\(\")(udev\"\\),\\s*[0-9]+\\);)" _ a b)
+ (string-append a (assoc-ref inputs "eudev") "/lib/lib" b)))
+ #t))))))
(synopsis "Qt Serial Port module")
(description "The Qt Serial Port module provides the library for
interacting with serial ports from within Qt.")))
e. New procedure. * po/guix/POTFILES.in: Add it. * guix/scripts/system.scm (check-initrd-modules)[check-device]: Remove. Use 'check-device-initrd-modules' instead. Ludovic Courtès 2018-03-05nls: Add Simplified Chinese translation.Ludovic Courtès 2018-02-26nls: Update 'pt_BR' translation.Marius Bakke 2018-02-19nls: Update 'fr' translation.Ludovic Courtès 2018-02-12nls: Update 'zh_CN' translation.Leo Famulari 2018-01-17nls: Update 'hu' translation.Leo Famulari 2017-12-18nls: Update 'hu' translation.Ludovic Courtès 2017-12-04nls: Update 'fr' translation.Ludovic Courtès 2017-11-28services: certbot: Add default value and description....* gnu/services/certbot.scm (certbot-service-type) [default-value, description]: New fields. * po/packages/POTFILES.in: Add it. Ludovic Courtès 2017-11-28services: cgit, git-daemon: Add description and default value....* gnu/services/version-control.scm (git-daemon-service-type) [description, default-value]: New fields. (cgit-service-type)[default-value]: New field. * po/packages/POTFILES.in: Add version-control.scm. Ludovic Courtès 2017-11-08gnu: Improve error reporting of the use-.*modules macros....Suggested by Julien Lepiller and myglc2 at <https://lists.gnu.org/archive/html/guix-devel/2017-11/msg00106.html>. * gnu.scm (%try-use-modules): New procedure. (package-module-hint, service-module-hint): New procedures. (try-use-modules): New macro. (use-package-modules, use-service-modules, use-system-modules): Use it. * tests/guix-system.sh: Test it. Ludovic Courtès 2017-09-16services: networking: Add descriptions....* gnu/services/networking.scm (static-networking-service-type) (ntp-service-type, inetd-service-type, tor-service-type) (tor-hidden-service-type, bitlbee-service-type) (wicd-service-type, network-manager-service-type) (connman-service-type, openvswitch-service-type): Add 'description' field. * po/packages/POTFILES.in: Add gnu/services/networking.scm. Ludovic Courtès 2017-09-16services: base: Add descriptions....* gnu/services/base.scm (fstab-service-type) (file-system-service-type, urandom-seed-service-type) (session-environment-service-type) (console-font-service-type) (login-service-type, agetty-service-type) (mingetty-service-type, nscd-service-type) (pam-limits-service-type, guix-service-type) (guix-publish-service-type, udev-service-type) (gpm-service-type): Add 'description' field. * po/packages/POTFILES.in: Add gnu/services/base.scm. Ludovic Courtès 2017-09-16guix system: Add 'search' command....* guix/scripts/system.scm (resolve-subcommand): New procedure. (process-command): Handle 'search'. (guix-system): Likewise. (show-help): Augment. * guix/scripts/system/search.scm: New file. * po/guix/POTFILES.in: Add it. * Makefile.am (MODULES): Add it. * guix/ui.scm (%text-width): Export. * doc/guix.texi (Invoking guix system): Document it. (Service Types and Services): Mention 'guix system search'. * tests/guix-system.sh: Test it. Ludovic Courtès 2017-09-02nls: Update 'fr' translation.Ludovic Courtès