aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorWojtek Kosior <koszko@koszko.org>2023-07-15 14:42:09 +0200
committerW. Kosior <koszko@koszko.org>2024-09-04 21:02:05 +0200
commit02eeb00edd97492ca54e39ca567bbb3d8ab6a582 (patch)
treed2d9fc62226847a33cec823067082c2ad9d04cef /gnu/packages
parent7d54645011034b855f3d1032803e9d5813355c20 (diff)
downloadguix-02eeb00edd97492ca54e39ca567bbb3d8ab6a582.tar.gz
guix-02eeb00edd97492ca54e39ca567bbb3d8ab6a582.zip
gnu: pantalaimon: Fix media downloads.
* gnu/packages/matrix.scm (pantalaimon)[arguments]: Patch incorrect function invokation that made downloads of attachments impossible
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/matrix.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 32ae62fcb4..395f4ba037 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -266,6 +266,14 @@ fledged batteries-included asyncio layer using aiohttp.")
;; Upgrading python-appdirs requires rebuilting 3000+ packages,
;; when 1.4.4 is a simple maintenance fix from 1.4.3.
(("appdirs >= 1.4.4") "appdirs >= 1.4.3"))))
+ (add-after 'downgrade-appdirs-requirement 'bugfixes
+ (lambda _
+ (substitute* "pantalaimon/daemon.py"
+ ;; FIXME: Remove this once a pantalaimon version with this fix
+ ;; is officially released.
+ ;; https://github.com/matrix-org/pantalaimon/pull/152/commits/d71770ca94981afde8c9be6aaaca951f0685b64e
+ (("client.download\\(server_name, media_id, file_name\\)")
+ "client.download(server_name=server_name, media_id=media_id, filename=file_name)"))))
(add-after 'install 'install-doc
(lambda _
(with-directory-excursion "docs/man"