aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:25:40 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:08 +0200
commit022482319d3c01864e0f69607cc93a2f572c461b (patch)
treed3c4cd8cd704ea0bc6c351dcb82d6b05dafa0a5c /gnu/packages
parenteb9305733e52cadf550650baae2de7bed93ac1b0 (diff)
downloadguix-022482319d3c01864e0f69607cc93a2f572c461b.tar.gz
guix-022482319d3c01864e0f69607cc93a2f572c461b.zip
gnu: emacs-xmlgen: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-xmlgen)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/emacs-xyz.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7c99b1455c..0d1404fa4d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6654,14 +6654,13 @@ fonts is supported.")
(version "0.5")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/philjackson/xmlgen/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/philjackson/xmlgen.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0zay490vjby3f7455r0vydmjg7q1gwc78hilpfb0rg4gwz224z8r"))))
+ (base32 "096i29v0badx0a6339h9ckdz78zj59gbjdp7vj7vhkq9d830392s"))))
(build-system emacs-build-system)
(arguments
`(#:tests? #t