aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/yubico.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-12-07 00:02:43 +0100
committerLudovic Courtès <ludo@gnu.org>2014-12-07 00:02:43 +0100
commit6036453fff4c92396a0c2fbbfabd6baa07164716 (patch)
treefcb8375d7467330987443bf50519d5dc8eed5e61 /gnu/packages/yubico.scm
parentc9e46f1c3967297ff14287f6d511d252a409518f (diff)
downloadguix-6036453fff4c92396a0c2fbbfabd6baa07164716.tar.gz
guix-6036453fff4c92396a0c2fbbfabd6baa07164716.zip
gnu: Add libyubikey and ykclient.
* gnu/packages/yubico.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/yubico.scm')
-rw-r--r--gnu/packages/yubico.scm76
1 files changed, 76 insertions, 0 deletions
diff --git a/gnu/packages/yubico.scm b/gnu/packages/yubico.scm
new file mode 100644
index 0000000000..f2e8ff133c
--- /dev/null
+++ b/gnu/packages/yubico.scm
@@ -0,0 +1,76 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages yubico)
+ #:use-module (gnu packages)
+ #:use-module (guix licenses)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix build-system gnu)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages man)
+ #:use-module (gnu packages curl))
+
+(define-public libyubikey
+ (package
+ (name "libyubikey")
+ (version "1.12")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://developers.yubico.com/yubico-c/Releases/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1f0plzmr1gwry4rfgq9q70v6qwqny009hac289ad5m6sj7vqflxr"))))
+ (build-system gnu-build-system)
+ (synopsis "Development kit for the YubiKey authentication device")
+ (description
+ "This package contains a C library and command-line tools that make up
+the low-level development kit for the Yubico YubiKey authentication device.")
+ (home-page "https://developers.yubico.com/yubico-c/")
+ (license bsd-2)))
+
+(define-public ykclient
+ (package
+ (name "ykclient")
+ (version "2.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://developers.yubico.com/yubico-c-client/Releases/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1lw1j61rfjngs8vvv9m348zl4166zg24bq0dy72r44wiz79yic4j"))))
+ (build-system gnu-build-system)
+
+ ;; There's just one test, and it requires network access to access
+ ;; yubico.com, so skip it.
+ (arguments '(#:tests? #f))
+
+ (native-inputs `(("pkg-config" ,pkg-config)
+ ("help2man" ,help2man)))
+ (inputs `(("curl" ,curl)))
+ (synopsis "C library to validate one-time-password YubiKeys")
+ (description
+ "YubiKey C Client Library (libykclient) is a C library used to validate a
+one-time-password (OTP) YubiKey against Yubico’s servers. See the Yubico
+website for more information about Yubico and the YubiKey.")
+ (home-page "https://developers.yubico.com/yubico-c-client/")
+ (license bsd-2)))