aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xorg.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-11-13 17:55:08 +0530
committerArun Isaac <arunisaac@systemreboot.net>2022-11-13 22:18:59 +0530
commit1f017bf7d031f9aaef415a6b726bc488c733a9c4 (patch)
treeca000817d652cdb62e71cfaa38d80551cacdf034 /gnu/packages/xorg.scm
parent5ef933efa4d8f1b656f978023509222173ee6e9c (diff)
downloadguix-1f017bf7d031f9aaef415a6b726bc488c733a9c4.tar.gz
guix-1f017bf7d031f9aaef415a6b726bc488c733a9c4.zip
gnu: prosody: Update to 0.12.1.
* gnu/packages/messaging.scm (prosody): Update to 0.12.1. [inputs]: Add icu4c.
Diffstat (limited to 'gnu/packages/xorg.scm')
0 files changed, 0 insertions, 0 deletions
dd' style='width: 68.8%;'/>
1 files changed, 22 insertions, 10 deletions
diff --git a/nix/nix-daemon/guix-daemon.cc b/nix/nix-daemon/guix-daemon.cc
index 459c794f5d..6ffc8f04ad 100644
--- a/nix/nix-daemon/guix-daemon.cc
+++ b/nix/nix-daemon/guix-daemon.cc
@@ -27,6 +27,7 @@
#include <argp.h>
#include <unistd.h>
#include <sys/types.h>
+#include <exception>
/* Variables used by `nix-daemon.cc'. */
volatile ::sig_atomic_t blockInt;
@@ -170,18 +171,29 @@ main (int argc, char *argv[])
settings.useChroot = false;
#endif
- settings.processEnvironment ();
+ argvSaved = argv;
+
+ try
+ {
+ settings.processEnvironment ();
- /* FIXME: Disable substitutes until we have something that works. */
- settings.useSubstitutes = false;
- settings.substituters.clear ();
+ /* FIXME: Disable substitutes until we have something that works. */
+ settings.useSubstitutes = false;
+ settings.substituters.clear ();
- argp_parse (&argp, argc, argv, 0, 0, 0);
+ argp_parse (&argp, argc, argv, 0, 0, 0);
- if (geteuid () == 0 && settings.buildUsersGroup.empty ())
- fprintf (stderr, "warning: running as root is highly recommended, "
- "unless `--build-users-group' is used\n");
+ if (geteuid () == 0 && settings.buildUsersGroup.empty ())
+ fprintf (stderr, "warning: running as root is highly recommended, "
+ "unless `--build-users-group' is used\n");
- argvSaved = argv;
- run (nothing);
+ run (nothing);
+ }
+ catch (std::exception &e)
+ {
+ fprintf (stderr, "error: %s\n", e.what ());
+ return EXIT_FAILURE;
+ }
+
+ return EXIT_SUCCESS; /* never reached */
}
false. * doc/guix.texi (Database Services): Update documentation, and specify a different value for disabling connections via sockets. * gnu/tests/guix.scm (%guix-data-service-os): Use default PostgreSQL behaviour. * gnu/tests/monitoring.scm (%zabbix-os): Likewise. * gnu/tests/web.scm (patchwork-os): Likewise. Signed-off-by: Leo Famulari <leo@famulari.name> 2021-01-28services: postgresql: Add socket directory support.Mathieu Othacehe * gnu/services/databases.scm (postgresql-config-file-socket-directory): New procedure. (<postgresql-config-file>)[socket-directory]: New field. (postgresql-config-file-compiler): Honor it. (postgresql-activation): Create the socket directory if needed. * doc/guix.texi (Database Services): Document it. * gnu/tests/guix.scm (%guix-data-service-os): Adapt it. * gnu/tests/monitoring.scm (%zabbix-os): Ditto. * gnu/tests/web.scm (patchwork-os): Ditto. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>