aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xml.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-10-09 21:05:52 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:07 +0200
commitec28ce00fd14528a9ad4baca05128c76b1bab995 (patch)
treec32f87ac97cdae0ff6c361c1e669dac3323cfc52 /gnu/packages/xml.scm
parented4e9eebb420d0d96777971b474d42b65a0531a1 (diff)
downloadguix-ec28ce00fd14528a9ad4baca05128c76b1bab995.tar.gz
guix-ec28ce00fd14528a9ad4baca05128c76b1bab995.zip
gnu: libxslt: Set search-paths for XML and SGML catalogs.
According to xsltproc manpage it supports both XML_CATALOG_FILES and SGML_CATALOG_FILES for catalog lookup. Since the native-search-paths field is not thunked, doing (package-native-search-paths libxslt) can lead to module import cycles so we define a %libxslt-search-paths variable to avoid this kind of trouble. * guix/search-paths.scm (%libxslt-search-paths): New variable. * gnu/packages/xml.scm (libxslt)[native-search-paths]: Set to %libxslt-search-paths. * gnu/packages/perl.scm (perl-app-xml-docbook-builder)[native-search-paths]: Ditto. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/xml.scm')
-rw-r--r--gnu/packages/xml.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 3e7a14616f..7506b3d4e1 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -367,6 +367,7 @@ formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.")
xz))
(native-inputs
(list pkg-config))
+ (native-search-paths %libxslt-search-paths)
(description
"Libxslt is an XSLT C library developed for the GNOME project. It is
based on libxml for XML parsing, tree manipulation and XPath support.")