aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-12-20 11:16:48 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-12-22 14:08:47 +0800
commitc45c438db2f788366403cc708491faacc163e5ee (patch)
tree5214eff39448df5d80873882959cc60d908f2a3c /gnu/packages/xfce.scm
parent91b0a27fcdbb419afe938bd697ddc9d62de3f9f0 (diff)
downloadguix-c45c438db2f788366403cc708491faacc163e5ee.tar.gz
guix-c45c438db2f788366403cc708491faacc163e5ee.zip
gnu: tumbler: Update 4.20.0.
* gnu/packages/xfce.scm (tumbler): Update to 4.20.0. [native-inputs]: Remove dbus-glib. [arguments]: Add 'patch-configure phase for 'gdbus-codegen'. Change-Id: Ie661eae35d935c1e05952d7d5c20872be3ca492f
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 5619f2767c..e86341fef9 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -366,7 +366,7 @@ merging features essential for loading menus modified with menu editors.")
(define-public tumbler
(package
(name "tumbler")
- (version "4.18.2")
+ (version "4.20.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -374,12 +374,20 @@ merging features essential for loading menus modified with menu editors.")
"tumbler-" version ".tar.bz2"))
(sha256
(base32
- "0ymy6a0hbv5iainphgpd7dfi8snpg7zs7lyqq2cgiiza6p3fwc5m"))))
+ "102qwa8an7wdqf0hrqd5k51aiib3zww0iizsigllfrcjamyn9cbl"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'patch-configure
+ (lambda _
+ (substitute* "configure"
+ ;; XDG_CHECK_PACKAGE_BINARY requires an absolute path.
+ (("\\$PKG_CONFIG --variable=gdbus_codegen gio-2.0")
+ "type -p gdbus-codegen")))))))
(native-inputs
(list pkg-config intltool
- `(,glib "bin") ; need glib-genmarshal
- dbus-glib)) ; need dbus-binding-tool
+ `(,glib "bin"))) ; need glib-genmarshal and gdbus-codegen
(propagated-inputs
(list glib)) ; required by tumbler-1.pc
(inputs