aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-12-20 11:43:12 +0800
committer宋文武 <iyzsong@member.fsf.org>2024-12-22 14:08:47 +0800
commitb94eba693ec239e9c5411f71669b3e1d4ef5af3e (patch)
tree13b1cb1e398827f6b49aae6de0760d551dad1c08 /gnu/packages/xfce.scm
parent9f292ed5423ccc5d05bcca15fa1a8614d4a82f66 (diff)
downloadguix-b94eba693ec239e9c5411f71669b3e1d4ef5af3e.tar.gz
guix-b94eba693ec239e9c5411f71669b3e1d4ef5af3e.zip
gnu: xfce4-settings: Update to 4.20.0.
* gnu/packages/patches/xfce4-settings-defaults.patch: Adjust patch. * gnu/packages/xfce.scm (xfce4-settings): Update to 4.20.0. [arguments]: Use G-Expressions. Add 'patch-configure phase. [inputs]: Add gtk-layer-shell. [native-inputs]: Add glib:bin. Change-Id: I114e9605dafec5f3ab2b09618cfacd071464e5f7
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm24
1 files changed, 17 insertions, 7 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 4a502d75a4..e58b96bd4d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -731,7 +731,7 @@ allows you to shut down the computer from Xfce.")
(define-public xfce4-settings
(package
(name "xfce4-settings")
- (version "4.18.6")
+ (version "4.20.0")
(source (origin
(method url-fetch)
(uri (string-append "https://archive.xfce.org/src/xfce/"
@@ -739,20 +739,30 @@ allows you to shut down the computer from Xfce.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "1zkvcsgx3bnk8gwcgwg7656pw5p9a4xl1fv4divddv96c0dhbafr"))
+ "1ag5pimprxc12zgdbs27vngin97fc6l9ig7xzc0naacs8aiqsm13"))
(patches (search-patches "xfce4-settings-defaults.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--enable-pluggable-dialogs"
- "--enable-sound-settings"
- "--enable-upower-glib"
- "--enable-xrandr")))
+ (list #:configure-flags
+ #~(list "--enable-pluggable-dialogs"
+ "--enable-sound-settings"
+ "--enable-upower-glib"
+ "--enable-xrandr")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'patch-configure
+ (lambda _
+ (substitute* "configure"
+ ;; XDG_CHECK_PACKAGE_BINARY requires an absolute path.
+ (("\\$PKG_CONFIG --variable=gdbus_codegen gio-2.0")
+ "type -p gdbus-codegen")))))))
(native-inputs
- (list pkg-config intltool))
+ (list (list glib "bin") pkg-config intltool))
(inputs
(list colord
exo
garcon
+ gtk-layer-shell
libnotify
libxcursor
libxi