aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/xfce.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-26 07:08:03 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-26 07:08:03 +0200
commit9d074e16c7a9879d67c348c7b2d70b725adfbdfa (patch)
treec4c8dc52508717b3b7aa7c988924a03aa6eb83d8 /gnu/packages/xfce.scm
parentca7e310f7ac32354b2e693e9a0f783320952a8fc (diff)
parenteeb71d778f149834015858467fbeeb1276d96d1d (diff)
downloadguix-9d074e16c7a9879d67c348c7b2d70b725adfbdfa.tar.gz
guix-9d074e16c7a9879d67c348c7b2d70b725adfbdfa.zip
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/xfce.scm')
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 705fbecfeb..fed7360aa8 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -891,6 +891,34 @@ GIT integration to Thunar, it adds Subversion and GIT actions to the context
menu.")
(license gpl2+)))
+(define-public thunarx-python
+ (package
+ (name "thunarx-python")
+ (version "0.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/bindings/"
+ name "/" (version-major+minor version)
+ "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32 "08lz9pvx006a2fypg2q38p61jbhy0yswz8cizlxpiwfcqsvhpnln"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list pkg-config which))
+ (inputs
+ (list exo
+ thunar
+ python
+ python-pygobject
+ libxfce4ui
+ gtk+))
+ (home-page "https://gitlab.xfce.org/bindings/thunarx-python")
+ (synopsis "Python Bindings for Thunar")
+ (description
+ "These bindings allow one to create python plugins for Thunar.")
+ (license gpl2+)))
+
(define-public xfwm4
(package
(name "xfwm4")